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Introduction to the TI Connect™ Window

The TI Connect™ window is a tool that you can use to go directly to any of the
main tasks in the TI Connect™ software. From the TI Connect™ window, you
can access shortcuts to tasks in:

• TI Data Editor

• TI Device Explorer

• TI OS Restore

• TI Software Update

This section describes the TI Connect™ window, information on opening and
closing the TI Connect™ window, and information on setting up your devices
for use with TI Connect™ software.

TI Connect™ Window

The TI Connect™ window provides shortcuts in several different forms:
toolbar icons, software tool drop-down lists, and task drop-down lists.
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window control buttons - Buttons used to close, minimize, or

expand the window.

toolbar visibility button - A button used to hide or show the toolbar.

toolbar - Buttons (icons) that provide shortcuts to the TI Connect™

functions.This toolbar can be customized to suit the user needs.

(See "Customizing the Toolbar" on page 7).

tool task lists - Task drop-down lists grouped by software tool.

command task lists - Task drop-down lists grouped by command.

Opening the TI Connect™ Window

1. On your desktop, double-click Macintosh HD .

The Macintosh® hard drive opens.

2. Click the arrow by the Applications folder.

A list of applications on your hard drive opens.
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3. Navigate to the TI Connect folder.

4. If the TI Connect folder is not open, click the arrow by the folder.

A list of TI Connect™ tools and folders opens.

5. Double-click TI Connect.

The TI Connect™ window opens.
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Closing the TI Connect™ Window

You must close the TI Connect™ window from the menu bar, rather than the
window. If you close the tool from the window, the window closes but the
software remains open.

▶ In the menu bar, click TI Connect > Quit TI Connect.

Connecting and disconnecting TI handheld devices

Connect your TI graphing calculators to your computer using either of the
following TI Connectivity Cables:

• USB Silver Edition cable

• USB computer cable (TI-84 Plus Family and TI-89 Titanium devices
only)

You should connect your devices each time you start the TI Connect™
software and then disconnect them when you finish. This helps the software
to recognize which devices you are using.

To connect TI handheld devices (USB Silver Edition cable)

1. Connect the USB Silver Edition cable to the device I/O port.

2. Connect the USB Silver Edition cable to the computer USB port.
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If TI Software Update is running, the device appears in the window.

Note: If TI Software Update is running and the device does not appear in
the window, repeat steps 1 and 2.

To connect TI handheld devices (USB computer cable)

1. Connect the USB computer cable to the device USB port.

2. Connect the USB computer cable to the computer USB port.

If TI Software Update is running, the device appears in the window.

Note: If TI Software Update is running and the device does not appear in
the window, repeat steps 1 and 2.

To disconnect TI handheld devices (USB Silver Edition cable)

1. Disconnect the USB Silver Edition cable from the computer USB port.

2. Disconnect the USB Silver Edition cable from the device I/O port.

Note: If TI Software Update does not automatically remove disconnected

devices from the window, click Refresh .

To disconnect TI handheld devices (USB computer cable)

1. Disconnect the USB computer cable from the computer USB port.

2. Disconnect the USB computer cable from the device USB port.

Note: If TI Software Update does not automatically remove disconnected

devices from the window, click Refresh .

Using Task Shortcuts

The main purpose of the TI Connect™ window is to provide shortcuts to the
tasks you are most likely to want to perform in the TI Connect™ software. You
can access task shortcuts for TI Data Editor, TI Device Explorer,
TI OS Restore, and TI Software Update.

If the tool you want shortcuts for is not in the toolbar, you can add it to the
toolbar. (See "Adding items to the toolbar" on page 8.)

To select a task:

1. In the toolbar, click the tool name or tool icon.

Introduction to the TI Connect™Window 5



A list of tasks for that tool opens.

2. Click the desired task.

The TI Connect™ software opens the appropriate tool and performs the

selected task.

Using Tool Task List Shortcuts

The center of the window contains the tool task list. This part of the
TI Connect™ window divides the available tasks by their tool (TI Data Editor,
TI Device Explorer, TI OS Downloader, and TI Software Update). Each tool
task contains its own drop-down list to access the shortcuts available within
that tool.

1. Determine the tool the desired task is under. (See Available task

shortcuts.)

2. From the drop-down list, select the desired task.

TI Connect™ opens the appropriate tool and performs the selected task.

Using Command Task List Shortcuts

The command task list is located at the bottom of the screen. These task lists
sort all available tasks by their command category (Create, View/Edit, and
Other) and not by the tool that houses the functionality. The command task
list contains all of the task shortcuts that are provided by the TI Connect™
window.

1. Select the command you want (Create, View/Edit, or Other).

2. From the selected command drop-down list, pick the desired task.

The TI Connect™ software opens the appropriate tool and performs the

desired task.

Available Task Shortcuts

Shortcuts are accessible from the TI Connect™ window using:

• the toolbar icons,

• each tool’s drop-down task list, or

• the command drop-down task lists.
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TI Data Editor Task Shortcuts

TI Data Editor task shortcuts include:

• Create a matrix

• Create a text file

• Create a list

• Create a program

• Create a string

• Create a group

• Create a number

• Open file from device

TI Device Explorer Task Shortcuts

TI Device Explorer task shortcuts include:

• View device screenshot

• Set device clock

• View device information

• View device content

• Send files to devices

• Copy files to computers

TI OS Restore Task Shortcut

The TI OS Restore task shortcut:

• Restore device operating system

TI Software Update Task Shortcut

The TI Software Update task shortcut:

• Update my device

Customizing the Toolbar

You can customize the TI Connect™ window toolbar. You can choose from a
variety of options, ranging from adding new items to the toolbar to changing
the display of the icons.
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Hiding and showing the toolbar

To hide the toolbar

▶ Click View > Hide Toolbar.

The window no longer shows the toolbar.

To show the toolbar

▶ Click View > Show Toolbar.

The window shows the toolbar.

Removing items from the toolbar

To remove items from toolbar

1. Click View > Customize Toolbar.

2. Drag the unwanted toolbar item to the Customize Toolbar dialog box.

The software removes the item from the toolbar.

3. Click Done.

Adding items to the toolbar

To add items to the toolbar

1. Click View > Customize Toolbar.
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2. Drag the additional item to the toolbar in the main window.

The software adds the item to the toolbar.

3. Click Done.

Setting the toolbar to the default

When you first open a tool it shows a default toolbar. If you change the
toolbar and decide you do not want to keep the changes, you can always
revert back to the default.

To set the toolbar to the default

1. Click View > Customize Toolbar.

2. Drag the default set to the toolbar in the main window.

The software reverts back to the default.
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3. Click Done.

Changing the display of icons and text

You can choose to display both icons and text, only icons, or only text in the
toolbar.

To change the display of icons and/or text

1. Click View > Customize Toolbar.

2. From the Show drop-down list, select the option you want.

The toolbar display in the main window changes.

3. Click Done.

Changing the size of toolbar icons

Changing the size of the toolbar icons can help you to find and use them
more quickly.

To change the size of the icons

1. Click View > Customize Toolbar.
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2. Select the Use small size check box to decrease the size of the icons.

Clear the check box to increase the size.

3. Click Done.

Troubleshooting

If you have trouble using the TI Connect™ window, visit
education.ti.com/go/download or send questions to Texas Instruments. If
your trouble is with a specific task, see the help for that tool.

If you encounter a problem while using TI Software Update that appears to
be an issue with the software, you can alert Texas Instruments to the
situation.

To send questions to Texas Instruments

1. Click TI Software Update > Send Questions to TI....

The Feedback dialog opens.
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2. Type a subject for the feedback.

3. In the main window, type the relevant information.

4. Click Send.
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Introduction to TI Device Explorer

With the TI Device Explorer tool, you can:

• Exchange information between your device and computer.

• Manage the files on your device.

• Capture screens from any connected TI graphing calculator.

• Create distribution lists to organize or locate the devices connected to
your computer.

• Connect to other devices and share information, files, and data with
these devices.

• Find information about a connected TI graphing calculator.

• Manage the date and time on connected TI-84 Plus Family devices,
TI-89 Family devices, the TI-92 Plus device, and the Voyage™ 200
Personal Learning Tool.

TI Device Explorer windows

The TI Device Explorer window contains tools for you to work with device
files, find device information, capture device screens, use distribution lists,
and manage device date and time. It has two views, normal view and
merged view. Normal view shows the connected devices and files, while
merged view shows a combined list of files on the connected devices.

Note: You can connect multiple devices such as several TI-84 Plus C Silver
Edition graphing calculators to manage files.
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TI Device Explorer window (normal view)

À window control buttons - Buttons used to close, minimize, or

expand the window.

Á toolbar visibility button - Hides or shows the toolbar.

Â
toolbar - Contains a set of buttons that provide shortcuts to specific

TI Device Explorer functions.

Ã
title bar - Identifies the type of information listed below it, including

file name, status, file restrictions, and file type.

Ä device list - Lists the connected devices.

Å device directory - Lists the files on one device.
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TI Device Explorer window (merged view)

À window control buttons - Buttons used to close, minimize, or

expand the window.

Á toolbar visibility button - Hides or shows the toolbar.

Â
toolbar - Contains a set of buttons that provide shortcuts to specific

TI Device Explorer functions.

Ã
title bar - Identifies the type of information listed below it, including

file name, status, file restrictions, and file type.

Ä file directory - Lists the files on all connected devices.

Screen Capture windows

TI Device Explorer has two windows that show captured screens. The
Screen Capture window for normal view shows the captured screen for one
device. The Screen Capture window for merged view shows captured
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screens for all connected devices.

Screen Capture window (normal view)

window control buttons - Buttons used to close, minimize, or

expand the window.

toolbar visibility button - Hides or shows the toolbar.

toolbar - Contains a set of buttons that provide shortcuts to specific

TI Device Explorer functions. If the window does not show all of the

tools, click the extended toolbar to expand the options.

image display - Shows the screen image captured from the

connected device.

help button - Opens the help documentation for the current feature.
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Screen Capture window (merged view)

window control buttons - Buttons used to close, minimize, or

expand the window.

image display - Shows the screen images captures from the

connected devices.

help button - Opens the help documentation for the current feature.

refresh button - Refreshes (updates) the screen image.

Device Information windows

TI Device Explorer has two windows that contain information about your
device. The Device Information window for normal view contains device
information for a specific device. The Device Information window for merged
view contains device information for all connected devices.
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Device Information window (normal view)

window control buttons - Buttons used to close, minimize, or

expand the window.

main viewing area - Displays detailed information about your

device. The Product ID is the unique number assigned to your

device.

Device Information Window (merged view)
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window control buttons - Buttons used to close, minimize, or

expand the window.

title bar - Names the type of information below it, such as Product

Name, Product ID, Language, OS Version, and so on.

main viewing area - Displays information about the connected

device(s).

Distribution List drawer

The Distribution List drawer enables you to create, use, and delete
distribution lists. Use distribution lists to filter the devices the TI Device
Explorer window displays in the window. In addition, you can use the error
distribution lists to resend files when transfers fail.

Introduction to TI Device Explorer 19



Distribution List drawer

distribution lists window - Lists the currently-available
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distribution lists.

error distribution lists window - Contains the error

distribution lists created from failed file transfers.

help button - Opens the help documentation for the current

feature.

distribution list control buttons - Control the deletion and

creation of distribution lists.

Device Hosts drawer

Use the Device Hosts drawer to view and connect to other computers (and
the devices attached to them) on the LAN currently in use To use other
features of Device Explorer, you must first create a device host for each
device you want to interact with. This drawer enables you to create these
device hosts.

Device Hosts drawer
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title bar - Describes the type of information on the window such as

device host names.

device host window - Displays the current device hosts.

device host buttons - Let you create and delete device hosts.

help button - Opens the help documentation for the current feature.

connection buttons - Let you connect or disconnect to TI Connect™

software users for whom you have established device hosts.

Opening TI Device Explorer

To open TI Device Explorer

1. On your desktop, double-click Macintosh HD .

2. Click the arrow by the Applications folder.

22 Introduction to TI Device Explorer



3. Navigate to the TI Connect™ folder.

4. If the TI Connect™ folder is not open, click the arrow by the folder.

5. Double-click TI Device Explorer.
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Note: If the TI Device Explorer window does not show the correct device(s),

disconnect the TI Connectivity Cable(s), and then reconnect them. It is

important that the graphing calculator(s) are turned on.

Closing TI Device Explorer

You must close TI Device Explorer from the menu bar, rather than the
window. If you close TI Device Explorer from the window, the window closes
but the software remains open.

To close TI Device Explorer

▶ In the menu bar, click TI Device Explorer > Quit TI Device Explorer.

Switching between merged and normal view

In normal view, the main viewing area contains icons for each device that
you have connected to the computer. You can then view the files on each
device under the device icons. In merged view, the main viewing area
contains a merged list of the files for all connected devices.
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To switch frommerged view to normal view

▶ Click View > Normal View or click Normal View .

To switch from normal view to merged view

▶ Click View > Merged View or click Merged View .

Changing the size of window icons

Changing the size of the window icons reduces or increases the amount of
space that the device name and files use. This can make it easier to locate
the device or file you need.
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To reduce the size of window icons

▶ Click and slide the arrow to the left .

To increase the size of window icons

▶ Click and slide the arrow to the right .

Setting preferences

When you start TI Device Explorer, it starts with certain predetermined
settings. You can change some of these settings under TI Device Explorer
Preferences. The settings you can change include some of the warning
dialog, screen capture, and clock features.

To change TI Device Explorer preferences

1. Click TI Device Explorer > Preferences.

The software indicates currently-selected preferences with a check

mark.

2. To clear any preferences, click the respective check mark.

3. To select any preferences, click the respective box.

4. Click Close .
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Connecting and disconnecting TI graphing calculators

You can connect your TI graphing calculators to your computer using either
of the following TI Connectivity Cables:

• USB Silver Edition cable

• USB computer cable (TI-84 Plus Family and TI-89 Titanium devices
only)

You should connect your devices each time you start the TI Connect™
software, and then disconnect them when you finish. This helps the software
to recognize which devices you are using.

Note: It is important that the graphing calculator(s) are turned on.

To connect TI graphing calculators (USB Silver Edition cable)

1. Connect the USB Silver Edition cable to the device’s I/O port.

2. Connect the USB Silver Edition cable to the computer’s USB port.

If TI Device Explorer is running, the device appears in the window.

To connect TI graphing calculators (USB computer cable)

1. Connect the USB computer cable to the device’s USB port.

2. Connect the USB computer cable to the computer’s USB port.

If TI Device Explorer is running, the device appears in the window.

To disconnect TI graphing calculators (USB Silver Edition cable)

1. Disconnect the USB Silver Edition cable from the computer’s USB port.

2. Disconnect the USB Silver Edition cable from the device’s I/O port.

To disconnect TI graphing calculators (USB computer cable)

1. Disconnect the USB computer cable from the computer’s USB port.

2. Disconnect the USB computer cable from the device’s USB port.

Refreshing devices in the window

Refreshing the window tells the software to detect changes to the connected
TI graphing calculators. For instance, this action detects if a device is no
longer connected or has new software.
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To refresh devices in the window

▶ Click File > Refresh or click Refresh .

TI Device Explorer connects to the attached device(s), determines any

changes, and refreshes the information in the window.

Note: If this step does not refresh the devices in the window, disconnect
the TI Connectivity Cable(s) from the computer and then reconnect

them. It is important that the graphing calculator(s) are turned on.

Renaming devices

Renaming devices makes it easier for you to distinguish between connected
devices.

To rename devices

1. If TI Device Explorer is not in normal view, click View > Normal View or

click Normal View .

2. Click the device you want to rename.

3. Press Enter.

The device name moves to a blue box under the Name field.

4. Type the new device name.

5. Click in the main window outside of the blue box.

TI Device Explorer renames the device.

Working with files

The TI Device Explorer tool enables you to manage device-related files on
your TI graphing calculator as well as on your computer. With this tool, you
can exchange information and files between your calculator and computer,
share information and files with other TI Connect™ software users, and
directly manage the files residing on your calculator.
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Opening files

You can open any data variable file in the TI Device Explorer window, as
well as the TI Device Explorer tool files. This helps you determine the
information available on your device and or choose the files that you want to
use.

To open files

1. In TI Device Explorer, navigate to the file you want to open.

2. Click the file.

3. Click File > Open.

Notes:

• The content of the Alert dialog box varies depending on the type of

file.

• This warning dialog is not displayed if you clear it under

Preferences. (See "Setting preferences" on page 26.)

4. Click Choose Application.

Choose an application that opens the appropriate window or tool.

5. Click Open.

Searching for files

Locating a specific file on your device to work with can be difficult if your
device contains a large number of files.

Before you start

Make sure the TI Device Explorer toolbar contains the search icon. (See
"Adding items to the toolbar" on page 80.)
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To search for files

1. Click Search .

TI DeviceExplorer outlines the icon with blue.

2. Type the name of the file.

In the main viewing area, TI Device Explorer shows a list of matching

files.

Copying files to computers

Copying device files to your computer creates backup files that you can use
in the future.

Warning: Do not disconnect a device during a transfer.

To copy files to the computer

1. In TI Device Explorer, navigate to the file you want to copy.

2. Click the file.

3. Click File > Save Selected Items to Disk or click Save to Disk .
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4. Navigate to the location where you want to save the copied file.

5. Click Save.

TI Device Explorer copies the file to your computer.

Note: If you are using a TI-82 or TI-85 device, the Alert dialog opens.
Follow the additional steps in the dialog to complete the copy. (See “If

you have a TI-82 or TI-85 device” below.)

If you have a TI-82 or TI-85 device

If you have a TI-82 or TI-85 device, you must follow some additional steps
after you complete step 5 of “Copying files to computers”.

1. On your device, press 2nd Link.

2. Select the files you want to send.

3. In the dialog, click Proceed.

4. On your device, select TRANSMIT, and then press Enter.

Sending files to connected devices

Sending files to connected devices enables you to install software, send
data variables, and restore backed-up (copied) files. You can send files from
the hard drive or the desktop.

Warning: Do not disconnect a device during a transfer.

Note: The software may not support all characters. During the send
operation, the software converts unsupported characters into question

marks.

To send files to connected devices

1. Click File > Send File to Selected Devices > Send or click Send to

Devices .
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2. Navigate to the file you want to send.

3. Click the file.

4. Click Send to Device.

TI Device Explorer sends the file to the connected device.

If a Panel window appears, type a name or select a name from the drop-

down list, and then click OK.

Note: If you using a TI-82 or TI-85 device, the Alert dialog opens. Follow
the additional steps in the dialog to complete the send.

If you are using a TI-82 or TI-85 device

If you have a TI-82 or TI-85 device, you must follow some additional steps
after step 4 in “Sending files to connected devices”.

1. On your device, press 2nd Link.

2. Select RECEIVE.

3. Press Enter.

4. In the dialog, click Proceed.

Compatibility with graphing calculators

Note: Not all TI-84 Plus C Silver Edition graphing calculator files are

compatible with other TI-84 Plus Family graphing calculator files because of

the high resolution of the TI-84 Plus C Silver Edition color screen. In general,
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numeric files (not limited to lists, variables, matrices, and functions) are

shared between these graphing calculators but Apps are not shared

between these graphing calculators even if they have the same title. When

incompatible, the computer file extensions for the TI-84 Plus C Silver Edition

are different from a similar variable from the TI-84 Plus/TI-84 Plus Silver

Edition graphing calculators.

File Type

Link from
TI-84 to
TI-84 Plus

C

Link from
TI-84 Plus
C to TI-84

84P
computer
file type

84PC
computer
file type

Operating

System

No No 8xu 8cu

Apps No No 8xk 8ck

AppVar* Yes Yes 8xv 8xv

Programs -

TI Basic*

Yes Yes 8xp 8xp

Assembly

Programs*

Yes No 8xp 8xp

Pictures No No 8xi 8ci

Background

Images

N/A No N/A 8ca

Group Files Yes Yes 8xg 8xg

User Zoom Yes Yes 8xz 8xz

String Yes Yes 8xs 8xs

Table Yes Yes 8xt 8xt

Function file Yes Yes 8xy 8xy

GDB* Yes Yes 8xd 8xd

Introduction to TI Device Explorer 33



File Type

Link from
TI-84 to
TI-84 Plus

C

Link from
TI-84 Plus
C to TI-84

84P
computer
file type

84PC
computer
file type

List Yes Yes 8xl 8xl

Matrix Yes Yes 8xm 8xm

Number Yes Yes 8xn 8xn

Complex Yes Yes 8xc 8xc

Window

Setup

Yes Yes‘ 8xw 8xs

Certificate No No 8xq 8cq

Backup No No 8xb 8cb

* Programs created using commands available only in the latest OS version

will not transfer to graphing calculators with an earlier OS version.

* App Vars and Programs should be reviewed for use after the transfer

between the TI-84 Plus Family and the TI-84 Plus C Silver Edition graphing

calculators. Some App Vars may not setup an App as expected. Some

Programs will need to be modified due to the difference in screen resolution

and new commands.

** You may receive a version error if you used DOT-THIN line style. Change

the line style to avoid the error.

Deleting files

You can use TI Device Explorer to delete files from your TI graphing
calculator.

Warning: You cannot undo the deletion of a file.

To delete files from a device

1. In TI Device Explorer, navigate to the file you want to delete.

2. Click the file.
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3. Click Edit > Delete or click Delete .

Note: This alert is not displayed if you clear the respective option in

Preferences. (See "Setting preferences" on page 26.)

4. Click OK in the confirmation window.

TI Device Explorer deletes the file from the device.

Backing up device files

A backup folder contains copies of the files currently on your TI graphing
calculator. You should perform an occasional backup to ensure that you do
not lose any important files.

Warning: Do not disconnect a device during a transfer.

Before you start

• Make sure your device is turned on and properly connected.

• Make sure the TI Device Explorer screen is in normal view.

To back up device files

1. Click the device you want to back up.

2. Click File > Save Selected Items to Disk or click Save to Disk .
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3. Navigate to the location where you would like to save the backup folder.

4. Click Save.

TI Device Explorer downloads the device files and stores them in a

backup folder on the computer.

Note: To view the download progress, clickWindow > History.

Working with device screens

The TI Device Explorer tool enables you to capture screens from any
connected TI graphing calculator. Once you capture a screen, you can save
it and or use it with other applications on your computer. This gives you the
ability to place accurate representations of a device screen into any
document.

Capturing device screens

You can capture a device screen from any TI graphing calculator connected
to your computer. The captured screen appears in the Screen Capture
window. You have the ability to use it as-is, add a border, or save just
selected portions of the screen.

Before you start

Make sure your device(s) are turned on and properly connected to your
computer.

To capture device screens (normal view)

1. On a connected device, display the screen you want to capture.

2. In the TI Device Explorer window, click the device whose screen you

want to capture.

3. Click Device > Capture screens or click Screen Capture .
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To capture device screens (merged view)

1. On the connected device(s), display the screen(s) you want to capture.

2. Click Device > Capture screens or click Screen Capture .

Note: If you cannot see all of the captured screens, click Expand .
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Refreshing captured screens

When the image on your device changes, you can refresh the captured
screen shown in the image display of the Screen Viewer window. You can
refresh the captured screen image after you make the change on your
device, or you can have the software continuously refresh the captured
screen image.

Note: To continuously refresh the captured screen, you must capture the

original screen in normal view.

To refresh the captured screen after a change (normal view)

▶ In the Screen Viewer window, click Extended Toolbar > click Refresh
The software refreshes the captured screen image to the newest image

on your device.

To refresh the captured screen after a change (merged view)

▶ In the Screen Viewer window, click .
The software refreshes the captured screen image to show the newest

images on your device(s).

To refresh the captured screen continuously (normal view only)

▶ In the Screen Viewer window, click Extended Toolbar > click Auto-
Refresh.

The software refreshes the captured screen image whenever the image

changes on your device.

To stop refreshing the captured screen continuously in both normal
view and merged view:

▶ In the Screen Viewer window, click Extended Toolbar > click Stop
Refreshing.

The software refreshes the captured screen image whenever the image

changes on your device.
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Editing captured screens

For images captured in normal view, you can resize the captured screens
and add borders to them. If you need to edit a captured screen in any other
way, then copy the screen into an image editor and make the changes there.

Note: You cannot resize or add borders to images captured from merged

view.

To resize captured screens (normal view only)

▶ To increase the captured screen’s size, click View > Zoom Out or click

Zoom Out .

▶ To decrease the captured screen’s size, click View > Zoom In or click

Zoom In .

To add or remove borders (normal view only)

▶ To add a border, click Edit > Draw Screen Border or click Draw Border .

▶ To remove a border, click Edit > Remove Screen Border or click Remove

Border .

To edit captured screens in an image editor

1. Open the image editor.

2. Drag the captured screen to the image editor.

3. Use the image editor’s tools to edit the image.

4. (Optional) In the image editor, save the captured screen.

Saving captured screens

Saving a captured screen gives you the ability to use it in other documents
or send it to other people. TI Device Explorer can also save screens in
different image formats.

Note: If you want to save a border to the screen, you must capture and save

the screen in normal view.

To save captured screens (normal view)

1. If necessary, edit the captured screen.

2. Click the captured screen and hold down the mouse button.
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The cursor becomes a closed hand. A transparent copy of the captured

screen appears.

3. Drag the transparent copy to the desktop.

TI Device Explorer creates a picture clipping file and puts it on the

desktop.

4. Click the name of the picture clipping file.

5. Type a new name and press Enter.

To save captured screens (merged view)

1. Drag the captured screen to the desktop.

TI Device Explorer creates a picture clipping file and puts it on the

desktop.

2. Click the name of the picture clipping file.

3. Type a new name and press Enter.

Note: To save picture clipping files to your hard drive, open the Macintosh

HD to the desired location and drag the picture clipping file there.
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Saving sections of captured screens

TI Device Explorer gives you the option of saving only selected sections of
captured screens. You may want to save selected parts of captured screens
when you only need a small part of the screen for a document.

Before you start

Make sure you captured the screen in normal view.

To save sections of captured screens

1. If necessary, edit the captured screen. (See "Editing captured screens"

on page 39.)

2. Click the captured screen and drag your cursor over the section you

want to capture.

A box forms around the selected section.

Note: If necessary, you can adjust the size of the selection. Hold your

cursor over any corner of the box until an arrow appears, then drag the

corner to the needed size.

3. Click the selected section and hold down the mouse button.

The cursor becomes a closed hand. A transparent copy of the selected

section may appear.
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4. Drag the image to the desktop.

TI Device Explorer creates a picture clipping file and puts it on the

desktop.

5. Click the name of the picture clipping file.

6. Type a new name and press Enter.

Note: To save the picture clipping file to your hard drive, open the Macintosh

HD to the desired location and drag the picture clipping file there.

Copying captured screens

Once you capture a screen, you may want to use it in various projects. You
can copy your captured screens and import them into other documents.
TI Device Explorer enables you to copy captured screens from either normal
view or merged view.

Note: If you want the captured screen to have a border, then you must copy it
from normal view.

To copy captured screens into documents (normal view)

1. If necessary, edit the captured screen. (See "Editing captured screens"

on page 39.)
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Note: Resized images return to the default size when you paste them in

the document. If you want a resized image to retain its size, drag the

image to the document.

2. Click Edit > Copy.

TI Device Explorer copies the captured screen and places it on the

clipboard.

3. Open the document into which you want to copy the captured screen.

4. Place your cursor in the location where you want the copied screen to

appear.

5. Click Edit > Paste.

The software puts a copy of the captured screen in the document.

To copy captured screens into documents (merged view)

1. Open the document.

2. Place your cursor in the location where you want the copied screen to

appear.

3. Drag the captured screen to the document.

The software puts a copy of the captured screen in the document.

Copying sections of captured screens

TI Device Explorer enables you to copy selected sections of captured
screens into other documents. This may help you if you need a small portion
of the captured screen in your document. You can only copy selected
sections from screens captured in normal view.

Before you start

Make sure you captured the screen in normal view.

To copy sections of captured screens into documents

1. If necessary, edit the captured screen. (See "Editing captured screens"

on page 39.)

2. Click the captured screen and drag your cursor over the section you

want to copy.
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Note: If necessary, you can adjust the size of the selection. Hold your

cursor over any corner of the box until an arrow appears, then drag the

corner to the needed size.

3. Click Edit > Copy.

TI Device Explorer copies the selected section and places it on the

clipboard.

4. Open the document into which you want to copy the selected section.

5. Place your cursor in the location where you want the copy to appear.

6. Click Edit > Paste.

The software puts a copy of the selected section in the document.

Changing device screen background color

When you capture screens, you have the option of capturing them with a
white or a green background color. Note that you must decide upon and
select the background color prior to capturing a screen.

To capture screens with white backgrounds

1. Click TI Device Explorer > Preferences.
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2. If Display screen capture with green background is checked, click the

checkmark to clear the box.

3. Click Close .

To capture screens with green backgrounds

1. Click TI Device Explorer > Preferences.

2. If Display screen capture with green background is not checked, click

the box to select this option.

3. Click Close .
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Working with TI-84 Plus C Silver Edition Image screens

The TI Device Explorer tool enables you to manage Image Vars and Pic
Vars to display on a TI-84 Plus C Silver Edition.

Converting and Sending Image Vars to a TI-84 Plus C

The TI-84 Plus C has the ability to display background images (Image Vars)
as well as the familiar Pic Vars functionality of the TI-84 Plus. These
variables display in the graph area. TI-84 Plus C Image and Pic Vars will not
link to a TI-84 Plus given the difference in the screen resolution of the two
graphing calculators.

Image Vars

A TI-84 Plus C Image Var is created by converting your picture (gif, tif, png,
jpg, or bmp) to 83 x 133 pixels (width by height) using the TI Connect™
software. You can then send the Image Var to your TI-84 Plus C or save it to
your computer as an *.8ca file. An Image Var can also be loaded into the
TI-84 Plus C emulator view in TI-SmartView™ software.

Your picture may not display in the graph area as expected given the
conversion to the pixel dimensions of 83 x 133. The conversion to the Image
Var uses 16-bit color.

On the TI-84 Plus C, an Image Var displays as the background in the graph
area only. An Image Var will display scaled for the MODE screen settings of
Full, Horizontal, and Graph-Table preserving any mathematical modeling
done on an Image Var. Image Vars cannot be edited while working on the
TI-84 Plus C. Image Vars run and are stored in Archive memory.

Note: A screen capture of the graph area includes the full screen of the TI-84
Plus C, status bar, graph border, and the graph area. TI Connect™ software
allows you to crop the graph size area only to create an Image Var if desired.

Pic Vars

Pic Vars are created and modified on the TI-84 Plus C. Pic Vars are 266 x
166 pixels and use the 15 colors available on the TI-84 Plus C. Pic Vars
display as an overlay on the graph screen area exactly as on the TI-84 Plus.
Pics Vars display from the upper left corner of the graph area and do not
scale for the MODE screen settings Full, Horizontal, and Graph-Table. Pic
Vars can be opened to view in the TI Connect™ Screen Capture software.
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They can be saved as computer files with the file extension *.8ci. Pic Vars
run and are stored in Archive memory. Note that Pic Vars on the TI-84 Plus
run and are stored in RAM memory but also can be stored in Archive
memory. Please note this difference when clearing RAM.

Note: TI Connect™ software will not convert a Pic Var (*.8ci) to an Image Var
(*.8ca).

Creating and Sending Image Vars to your TI-84 Plus C

Background Image Vars are created, sent, or saved using either:

• TI Connect™ software for the Mac® using Device Explorer or Create

a Group

• TI Connect™ software for the PC using Device Explorer or Screen

Capture

Creating and Sending an Image Var to a Connected TI-84 Plus C

The following steps show you how to create an Image Var if you have a
TI-84 Plus C graphing calculator connected to your computer. You can
create the Image Var, save it to your computer, and display it in the graph
area of the TI-84 Plus C.

1. Choose the image you want to convert. Allowed picture file types are tif,

gif, png, jpg, or bmp.

2. Open TI Connect™ software.

3. Using the USB Computer Cable, connect the TI-84 Plus C to the

computer. Turn on the TI-84 Plus C.

4. Open Device Explorer.

5. Drag the picture to the Device Explorer.
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6. Select an Image# name from the drop-down menu, such as Image0 -

Image9. This will be the name of the image on the TI-84 Plus C.

Note: Since this Image# name is internal to the conversion process, it is
important to remember what Image# name you assigned. It is

recommended that you keep this information in the filename so you

know where the Image Var will be stored on the TI-84 Plus C if you send

or share this file in the future.

7. Click OK.

You can preview the Image Var, save it on your computer, and display it in
the graph area of the TI-84 Plus C.

• To preview the Image Var:

- On a PC, open Background and double-click the Image#. The

Image Var preview opens in the Screen Capture window.

- On a Mac®, expand the calculator directory and double-click the

Image#. The Image Var preview opens in a Preview window.

• To save the Image Var on your computer, drag the Image# from the TI
Connect™ Device Explorer to your desktop, or to the folder where you
want to save it.

• To display your new Image Var in the graph area of the TI-84 Plus C,
press 2nd FORMAT , change the Background setting to the Image# you
just sent to the device (example: Image5), and press GRAPH.
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TI Connect™ software for the PC: Creating an Image Var Without a
Connected Device

The following steps show you how to create an Image Var if you do not have
a TI-84 Plus C graphing calculator connected to your PC. You can create the
Image Var, save it to your computer, and load it into TI-SmartView™ software
to view.

1. Choose the image you want to convert. Allowed picture file types are tif,

gif, png, jpg, or bmp.

2. Open TI Connect™ software.

3. Open Screen Capture.

4. Drag the picture to Screen Capture.

5. Click File > Save As.

6. Choose the directory where you want to save the file.

7. Choose TI-84 Plus C Image (.8ca) as the file type.

8. Click Save.

9. Select an Image# name from the drop-down menu, such as Image0 -

Image9. This will be the name of the image on the TI-84 Plus C.

Note: Since this Image# name is internal to the conversion process, it is
important to remember what Image# name you assigned. It is

recommended that you keep this information in the filename so you

know where the Image Var will be stored on the TI-84 Plus C if you send

or share this file in the future.

10. Click OK to convert the image to a TI-84 Plus C (.8ca) file.

See the steps below for loading the Image Var into the TI-SmartView™
software.

TI Connect™ software for the Mac®: Creating an Image Var Without
a Connected Device

The following steps show you how to create an Image Var if you do not have
a TI-84 Plus C graphing calculator connected to your Mac®. The Create a
group feature is used to convert an image without a connected device. You
can create the Image Var, save it to your computer, and load it into TI-
SmartView™ software to view.
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1. Choose the image you want to convert. Allowed picture file types are tif,

gif, png, jpg, or bmp.

2. Open TI Connect™ software.

3. Click the Create drop-down menu at the bottom of the TI Connect™

window and choose Create a group.

4. Drag the picture from your desktop to the Group window.

5. Select the calculator you want to use.

6. Select an Image# name from the drop-down menu, such as Image0 -

Image9. This will be the name of the image on the TI-84 Plus C.

Note: Since this Image# name is internal to the conversion process, it is
important to remember what Image# name you assigned. It is

recommended that you keep this information in the filename so you

know where the Image Var will be stored on the TI-84 Plus C if you send

or share this file in the future.

7. Click OK to convert the image to a TI-84 Plus C (.8ca) file.

8. To save the Image Var on your computer, drag the Image# from the

Group window to your desktop, or to the folder where you want to save

it.

See the steps below for loading the Image Var into the TI-SmartView™
software.

Loading an Image Var into the TI-SmartView™ software for the
TI-84 Plus C Emulator View

Once your create and save an Image Var (.8ca) file using TI Connect™
software, you can load that file into the TI-84 Plus C emulator view in
TI-SmartView™ software, similar to any calculator file.

1. Select File > Load File in TI-SmartView™ software.

2. Select All Calculator Files (*.8c?).

3. Locate your Image Var. Remember that the internal image name of

Image# is in the file. In this example, the file was named BRIDGE_

IMAGE5.8ca. You will receive no prompt to pick a new Image#

calculator name.

4. Select Open and the file will load to the emulator.
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5. To display your new Image Var in the graph area of the TI-84 Plus C

emulator, press 2nd FORMAT , change the Background setting to the

Image# you just sent to the device (example: Image5), and press

GRAPH.

Working with distribution lists

Distribution lists help you organize or locate the devices that are connected
to your Local Area Network (LAN) and also running TI Connect™ software.
For example, with a distribution list you can easily locate all connected TI-83
Plus Silver Editions. Distribution lists are especially helpful when you have a
large number of different devices connected to your LAN and you want to
share data files with these devices.

Opening and closing the Distribution List drawer

You can open and close the Distribution List drawer from the menu bar or
the toolbar.

To open the Distribution List drawer

▶ Click View > Toggle Distribution List Drawer or click Distribution Lists

.

To close the Distribution List drawer

▶ Click View > Toggle Distribution List Drawer or click Distribution Lists

.

Creating normal distribution lists

If the available distribution lists do not meet your needs, you can create new
distribution lists.

To create normal distribution lists

1. If the distribution list drawer is not open, click View > Toggle Distribution

List Drawer or click Distribution Lists .
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2. Click New distribution list .

3. Type a List Name.
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4. Drag the devices you want in the distribution list from the TI Device

Explorer window to the new distribution list dialog.

5. Click Done.

TI Device Explorer creates the new distribution list and adds it to the

distribution list drawer.

Using error distribution lists

TI Device Explorer creates an error distribution list when an error occurs
during a send operation. TI Device Explorer names the error distribution list
based on the file that did not send correctly. In the error distribution list, you
can find all of the devices to which the software did not send the file. You can
then use the error distribution list to resend the file once you resolve the
problem that caused the send failure.

Notes:

• Although the error distribution list is named based on the sent file, it

does not contain the file.

• You cannot edit or intentionally create an error distribution list.
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To use error distribution lists

1. Resolve the error that caused the software to not send the file.

Note: You can determine the error using the history window. Click
Window > History and locate the explanation for why the send failed.

2. If the distribution list drawer is not open, click View > Toggle Distribution

List Drawer or click Distribution Lists .

3. Click the error distribution list for the file you want to resend.

The main window displays the devices to which the software did not

send the file.

4. Select the devices.

5. Resend the file. (See "Sending files to connected devices" on page 31.)

Creating dynamic distribution lists

If the available distribution lists do not meet your needs, you can create a
new distribution list. A dynamic distribution list differs from a normal list in the
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way devices are included on the list. For dynamic distribution lists,
TI DeviceExplorer searches for devices that satisfy specific criteria instead of
requiring you to manually locate each device you want included on the list.

To create dynamic distribution lists

1. If the distribution list drawer is not open, click View > Toggle Distribution

List Drawer or click Distribution Lists .

2. Click New dynamic distribution list .
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3. Type a Device list name.

4. Click either Match any of those criteria or Match all of those criteria.

5. Click the first criteria box and select a field from the drop-down list.

6. Click the second criteria box and select a field from the drop-down list.

7. Double-click the third criteria box and type the search data.

Note: If you selected Model or Family in step 5, you can click the arrow

by the third criteria box and select a field from the drop-down list.

8. If you want to add more criteria, click Add Criteria and repeat steps
5 - 7 for the new line of criteria boxes.

9. Click Done.

TI Device Explorer creates a dynamic distribution list and adds it to the

distribution list drawer.

Applying distribution lists

You can apply any distribution list to the list of devices in the TI Device
Explorer window. The selected distribution list limits the display of devices to
only those that match the criteria specified by the distribution list.

To apply distribution lists

1. If the distribution list drawer is not open, click View > Toggle Distribution

List Drawer or click Distribution Lists .
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2. Click the distribution list you want to apply.

TI Device Explorer locates devices that match the criteria specified in

the distribution list and shows them in its window.

Editing distribution lists

You may, on occasion, need to change a distribution list. For instance, you
may need to add another device or change the criteria. TI Device Explorer
lets you edit both normal and dynamic distribution lists.

To edit distribution lists

1. If the distribution list drawer is not open, click View > Toggle Distribution

List Drawer or click Distribution List .
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2. Double-click the distribution list you want to edit.

If the list is a normal distribution list, the normal distribution list window

opens.

58 Introduction to TI Device Explorer



If the list is a dynamic distribution list, the dynamic distribution list

window opens.

3. Make the necessary changes to the distribution list.

4. Click Done.

TI Device Explorer saves the changes to the distribution list.

Deleting distribution lists

If you decide that you no longer want a distribution list, you can delete it from
the distribution lists drawer.

Warning: You cannot undo the deletion of a distribution list.

To delete distribution lists

1. If the distribution list drawer is not open, click View > Toggle Distribution

List Drawer or click Distribution Lists .
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2. Click the distribution list you want to delete.

3. Click Delete .

TI Device Explorer removes the distribution list from the distribution list

drawer.

Restoring the Distribution List drawer

You can restore the Distribution List drawer to its default lists. By restoring
the distribution list drawer, you erase all of the lists you created.

Warning: You cannot undo the restoration of the distribution list drawer.

To restore the Distribution List drawer

1. Click Edit > Restore Distribution Lists.

2. Click Restore.
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TI Device Explorer restores the Distribution List drawer to its default lists.

Working with device hosts

With the Device Hosts drawer, you can connect yourself to the devices of
other people with TI Connect™ software on your Local Area Network (LAN).
Connecting yourself to the devices of other people lets you find information
on their devices and share information, files, and data with them.

To connect to the device of another person, you must have a device host for
them, and they must currently have the TI Connect software running.

Opening and closing the Device Hosts drawer

You can open and close the Device Hosts drawer from the menu bar or the
toolbar.

To open the Device Hosts drawer

▶ Click View > Toggle Device Hosts Drawer or click Device Hosts .

To close the Device Hosts drawer

▶ Click View > Toggle Device Hosts Drawer or click Device Hosts .

Creating device hosts

The Device Hosts drawer automatically creates device hosts to connect you
to anyone on your local area network using the TI Connect™ software. If you
want to connect to someone who is not on the local area network, create
your own device host.

To create device hosts

1. If the Device Hosts drawer is not open, click View > Toggle Device Hosts

Drawer or click Device Hosts .

Introduction to TI Device Explorer 61



2. Click Create a new device host .

3. In the new device host, double-click the word Untitled.

4. Type a name for the device host.

5. Press return.

TI Device Explorer sets the name of the device host to the typed name.

The new device host may change positions in the list.
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6. In the new device host, double-click the Network address.

A blue box forms around the Network address.

7. Type the Network address.

8. Click the name of the device host.

TI Device Explorer sets the address of the device host to the typed

Network address.

Creating device host groups

To connect with a large number of TI Connect™ users, create a device host
group. This makes your device hosts easier to find and use.

To create device host groups

1. If the Device Hosts drawer is not open, click View > Toggle Device Hosts

Drawer or click Device Hosts .
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2. Click Create new device host group .

3. In the new device host group, double-click the words Untitled Group.

4. Type a name for the device host group.

5. Click the highlighted section of the device host group.

64 Introduction to TI Device Explorer



TI Device Explorer sets the name of the device host group to the typed

name. The new device host group may change positions in the list.

6. Add device hosts to the device host group. (See "Adding device hosts to

device host groups" on page 65.)

Adding device hosts to device host groups

Once you create a device host group, you need to add device hosts to it. You
can add device hosts to your device host groups at any time.

To add device hosts to device host groups

1. Click the device host group.

2. Click Create a new device host .

3. Click the arrow to the left of the group.

4. In the list of device hosts, locate the device host named Untitled.

5. Double-click the word Untitled.
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6. Type a name for the device host .

7. Press tab.

TI Device Explorer sets the name of the device host to the typed name.

A blue box forms around the Network address.

8. Type the Network address.

9. Click the device host name.

10. TI Device Explorer sets the device host address to the typed Network

address.

Deleting Device hosts and device host groups

If you decide you no longer want a device host or device host group, you can
delete it from the Device Hosts drawer.

Warning: You cannot undo a deletion.

To delete device hosts and device host groups

1. If the Device Hosts drawer is not open, click View > Toggle Device Hosts

Drawer or click Device Hosts .
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2. Locate the device host or device host group you want to delete.

3. Click the device host or device host group.

4. Click Delete .

TI Device Explorer removes the device host or device host group from

the list.

Connecting to other users

The Device Host drawer enables you to connect to the devices of other
people currently using the TI Connect™ software. Once you connect to the
devices, you can use TI Device Explorer to exchange information with them.
For instance, you can send files to the devices and copy files from the
devices.

Before you begin

• Make sure Remote Apple Event Sharing is turned on. (System
Preferences: Sharing)

• Make sure you have an account username and password.

• Make sure the user with whom you need to connect is currently running
TI Connect Manager. That is, make sure that the Device Hosts drawer
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lists a device host for them. If necessary, create a device host for the
user. (See "Creating device hosts" on page 61.)

To connect to other TI Connect™ users

1. Click the user’s device host.

2. Click Connect.

3. Type your username.

4. Type your password.

5. Click OK.

TI Device Explorer connects you to the other TI Connect™ user. The

TI Device Explorer main window shows the user’s connected device(s).

If the remote computer is not running the TI Connect Manager software,

an error is displayed and no connected devices are shown in the main

window.
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Finding device information

You can use the TI Device Explorer tool to find information about a
connected TI handheld device. When you find device information, its display
depends on the view of the TI Device Explorer window.

• In merged view, the device information window displays information
about all of the connected devices.

• In normal view, the device information window displays information
about a single connected device.

Finding device information in normal view

In normal view, the device information window shows information about a
single connected device. The information includes the device’s product ID,
language, OS version, ROM version, battery state, hardware version, and
connection ID (Device Serial Number).

To find device information in normal view

1. In the main window, click a device.

2. Click Device > Device Information or click Device Information .

Finding device information in merged view

In merged view, TI Device Explorer shows the device information of all
connected devices in one window. The information in this window includes
the device’s name, product ID, language, OS version, ROM version, battery
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status, hardware version, and connection ID (Device Serial Number.)

To find device information in merged view

▶ Click Device > Device Information or click Device Information .

Managing date and time on TI graphing calculators

You can use TI DeviceExplorer to manage the date and time on connected
TI-84 Plus Family devices, TI-89 Family devices, TI-92 Plus devices, and
Voyage™ 200 Personal Learning Tools. This feature makes setting the date
and time on your TI graphing calculators easier and more convenient.

Note: TI-89 and TI-92 Plus devices with a hardware version of 1.0 and/or an
operating system lower than 2.08 do not support the date and time feature.

Synchronizing device date and time with computer

The quickest way to set your device date and time is to synchronize
connected devices with your computer. You can synchronize your TI-84 Plus
Family devices, TI-89 Family devices, TI-92 Plus devices, and Voyage™ 200
Personal Learning Tools. TI Device Explorer has automatic and manual date
and time synchronization.

To synchronize the device date and time automatically (normal or
merged view)

1. Click TI Device Explorer > Preferences.
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2. Select Synchronize device clock on device detection.

3. Click Close .

Each time you connect a device, TI Device Explorer automatically

synchronizes its date and time with the computer.

To synchronize device date and time with the computer manually
(normal view)

1. In the main window, click the device whose date and time you want to

synchronize.

2. Click Device > Edit Clock or click Clock Editor .
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3. Click Synchronize With Computer.

TI Device Explorer synchronizes the device date and time with your

computer.

To synchronize device date and time with the computer manually
(merged view)

1. Click Device > Edit Clock or click Clock Editor .
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2. Click Synchronize Devices With Computer.

TI Device Explorer synchronizes the date and time of all connected

devices with the date and time on your computer.

Setting the date on TI graphing calculators

With TI Device Explorer, you can set the date on your TI-84 Plus Family
devices, TI-89 Family devices, TI-92 Plus devices, and Voyage™ 200
Personal Learning Tools.

To set the date on devices (normal view)

1. Click the device whose date you want to set.

2. Click Device > Edit Clock or click Clock Editor .
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3. Click Next Month to go forward a month or click Previous Month to
go back a month.

4. Continue to click Next Month or Previous Month until you reach the

correct month and year.

5. In the calendar, click the correct day.

6. Under Display Options, use the date format drop-down list to select the

date format you want to use. Only valid formats for the device are listed.

7. Click Update.

TI Device Explorer sets the date on the selected device.

To set the date on devices (merged view)

1. Click Device > Edit Clock or click Clock Editor .
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2. Make sure the Date & Time field has a check mark in it. If it does not,

click the box in the upper left corner of the Date & Time field.

3. Click Next Month to go forward a month or click Previous Month to
go back a month.

4. Continue to click Next Month or Previous Month until you reach the

correct month and year.

5. In the calendar, click the correct day.

6. Under Display Options, use the date format drop-down list to select the

date format you want to use. Only valid formats for the device are listed.

7. Make sure that the box by the Date Format drop-down list has a check

mark in it. If it does not, click the box next to the Date Format drop-down

list.

8. Click Update.

TI Device Explorer sets the date on the selected device.
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Setting the time on TI graphing calculators

Using TI DeviceExplorer, you can set the time and clock type on your TI-84
Plus Family devices, TI-89 Family devices, TI-92 Plus devices, and Voyage™
200 Personal Learning Tools.

To set the time on devices (normal view)

1. Click the device whose time you want to set.

2. Click Device > Edit Clock or click Clock Editor .

3. Click the hour, minute, and second and make any necessary changes. If

you are using a 12-hour clock, select the AM/PM designator. If you want

to use a 24-hour clock, select Use 24 hour clock.

4. Click Update.

TI Device Explorer sets the time on the selected device.

To set the time on devices (merged view)

1. Click Device > Edit Clock or click Clock Editor .
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2. Make sure the Date & Time field has a check mark in it. If it does not,

click the box in the upper left corner of the Date & Time field.

3. Click the hour, minute, and second and make any necessary changes. If

you are using a 12-hour clock, select the Use 12 Hour Clock option from

the drop-down list. If you want to use a 24-hour clock, select the Use 24

hour Clock option.

4. Click Update.

TI Device Explorer sets the time on the selected device.

Turning TI graphing calculator clocks on or off

You can choose whether or not you want the clock to display on your TI-84
Plus Family devices, TI-89 Family devices, TI-92 Plus devices, and Voyage™
200 Personal Learning Tools.

To turn device clocks on or off (normal view)

1. Click the device whose clock you want to turn on or off.

2. Click Device > Edit Clock or click Clock Editor .
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3. Click Display clock on device.

If you are turning the clock on, a check mark appears in the box by

Display clock on device.

If you are turning the clock off, the software removes the check mark in

the box by Display clock on device.

4. Click Update.

TI Device Explorer turns the clock of the selected device on or off.

To turn device clocks on or off (merged view)

1. Click Device > Edit Clock or click Clock Editor .
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2. Make sure that the Clock Display drop-down list has a check mark by it.

If it does not, click the box by the Clock Display drop-down list.

3. Click Update.

TI Device Explorer turns the clock of the connected devices on or off.

Customizing the toolbar

When you customize the toolbar, you can choose from a variety of options,
ranging from adding new items to the toolbar to changing the display of the
icons. Customizing the toolbar makes the TI Device Explorer more
convenient and easier for you to use.

Hiding and showing the toolbar

You can choose whether or not you want to show the toolbar in the window.

To hide the toolbar

▶ Click View > Hide Toolbar.

The window no longer shows the toolbar.
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To show the toolbar

▶ Click View > Show Toolbar.

The window shows the toolbar.

Removing items from the toolbar

You can remove tools, separators, and spaces from the toolbar.

To remove items from toolbar

1. Click View > Customize Toolbar.

2. Drag the unwanted item to the Customize Toolbar sheet.

The software removes the item from the toolbar.

3. Click Done.

Adding items to the toolbar

You can add tools, separators, and spaces to the toolbar.

To add items to the toolbar

1. Click View > Customize Toolbar.
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2. Drag the additional item to the main window’s toolbar.

The software adds the item to the toolbar.

3. Click Done.

Setting the toolbar to the default

When you first open a tool it shows a default toolbar. If you change the
toolbar and decide you do not want to keep the changes, you can always
revert back to the default.

To set the toolbar to the default

1. Click View > Customize Toolbar.
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2. Drag the default set to the main window’s toolbar.

The software reverts back to the default.

3. Click Done.

Changing the display of icons and text

TI Device Explorer lets you change the icons and the text that are displayed
in the toolbar. You can choose to display both icons and text, only icons, or
only text.

To change the display of icons and/or text

1. Click View > Customize Toolbar.
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2. Click the Show pop-up menu.

3. Click the option you want.

TI Device Explorer changes the display of icons and/or text in the

toolbar.

4. Click Done.

Changing the size of toolbar icons

Changing the size of the toolbar icons helps you find and use them more
quickly.

To change the size of the icons

1. Click View > Customize Toolbar.
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2. Click Use Small Icons.

If Use Small Icons is off, TI Device Explorer turns it on. A check mark

appears and the icons in the toolbar become smaller.

If Use Small Icons is on, TI Device Explorer turns it off. The check mark

disappears and the icons in the toolbar become larger.

3. Click Done.

Troubleshooting

This section contains information to help you quickly solve any problems you
may encounter while using TI Device Explorer. If you are unable to find an
answer to your question here or in other sections of the help, visit the
education.ti.com/go/download.

Frequently-asked questions

To make this section easier to use, the questions are separated into the
following categories:

• See "General " on page 85

• See "Screen Capture" on page 86

• See "Clock Editor" on page 87

• See "Device Information" on page 87
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• See "Distribution List" on page 87

• See "Device Host drawer" on page 88

General

Q:What can I do when the software shows the wrong devices in the
window?

You can do either of the following:

• Click Refresh.

• Disconnect the TI Connectivity Cable(s) from the computer and then
reconnect them.

• It is important that the graphing calculator is turned on.

Q: How do I send a photo or picture to the TI-84 Plus C Silver Edition
graphing calculator?

• See "Working with TI-84 Plus C Silver Edition Image screens" on page
46.

• Drag your picture to the Device Explorer from your desktop when the
TI-84 Plus C Silver Edition graphing calculator is connected.

Q:What types of files can I open with TI Device Explorer?

You can open any data variable file, including matrices, text, list, program,
string, group, and number files.

Q:What is the difference between merged and normal view?

In merged view, TI Device Explorer contains a merged list of the files for all
connected devices. In normal view, TI Device Explorer sorts the files by
connected device.

Q: I have trouble getting my TI Presenter to appear in the device directory.
How can I fix this?

Try the following:

1. Disconnect the TI Connectivity Cable from both the TI Presenter and the

computer.

2. Connect the TI Connectivity Cable to the TI Presenter.

3. Connect the TI Connectivity Cable to the computer.

Introduction to TI Device Explorer 85



You may need to do this several times to get the TI Presenter to appear in
the device directory.

Q:Why can’t I open TI Device Explorer by clicking the icon at the bottom of
the screen?

You have minimized the TI Device Explorer window. Click its minimized icon
to open TI Device Explorer.

Q: How can I find out if my file downloaded/uploaded correctly?

In the TI Device Explorer menu bar, clickWindow > History to open the
History window. If your file downloads/uploads correctly, a blue check mark
appears. If your file does not transfer correctly, a yellow exclamation point
appears with an explanation.

Q:Why doesn’t TI Device Explorer show all of the files on my TI-82 / TI-85
device?

The TI-82 and TI-85 devices do not support a directory. The only files
TI Device Explorer shows for these devices are Screen and VarLink.

Q:Why does the file I sent to my device contain missing or inaccurate data?

The file you sent contains unsupported characters.

Q:When I try to create a backup folder on my hard drive, the process stalls
and I have to force quit TI Device Explorer. What causes this and how do I fix
it?

The device has an older operating system. If you update the operating
system, you should no longer have this problem.

Screen Capture

Q:Why does my screen capture appear distorted?

The device you tried to capture a screen for is not connected (or is
improperly connected) to your computer. Reconnect your device to the
computer, click Refresh in the TI Device Explorer window, and try again.

Q:Why does the Screen Capture window show a question mark instead of a
screen capture?

The device you tried to capture a screen for is not connected (or is
improperly connected) to your computer. Reconnect your device to the
computer, click Refresh in the TI Device Explorer window, and try again.

Q:Why can I not see all of the screens I captured in merged view?
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The window is not big enough. Click Expand or click the Arrows .

Q: Can I add a border to my captured screen?

Yes. You can add a border to an image captured in normal view. Click Draw

Border before you copy or save the captured screen.

Clock Editor

Q:Why doesn’t TI Device Explorer have a clock option for my
TI-89/TI-92 Plus device?

Your device has a hardware version of 1.0 and/or an operating system of
2.08 or lower. TI-89/TI-92 Plus devices with hardware version 1.0 and/or
operating systems 2.08 or lower do not support the clock feature.

Q: Can I send just one Clock Editor field to my device?

No. When you send a Clock Editor field (such as date or time) to your device,
the software sends all the other fields as well. Make sure the other fields are
correct before you send a new setting to your device.

Q:What date formats can I choose from?

You can choose any of the following formats: mm/dd/yy, dd/mm/yy,
mm.dd.yy, dd.mm.yy, yy.mm.dd, mm-dd-yy, dd-mm-yy, yy-mm-dd.

Note: Some devices may not have all of these options.

Q:What is the difference between a 12-hour clock and a 24-hour clock?

A 12-hour clock gives the time as AM/PM. For example, the time reads 6:30
AM in the morning and 6:30 PM at night. A 24-hour clock gives military time.
For example, the time reads 6:30 in the morning and 18:30 at night.

Device Information

Q: Can I save the device information as a file?

No, TI Device Explorer does not let you save device information as a file.

Distribution List

Q:What is a distribution list?

A distribution list is simply a way to locate devices. Each distribution list
contains a set of search criteria that TI Device Explorer uses to determine
which connected devices to show in the window.

Q:Why are the distribution lists I created not in the distribution list drawer?
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You may have restored the distribution lists. When you restore distribution
lists, TI Device Explorer removes any distribution lists you created.

Q: Can I change my distribution list after I create it?

Yes. You can change both normal and dynamic distribution lists. Double-
click the distribution list you want to change, make the changes in the
window, and click Done.

Device Host drawer

Q:What can I use the Device Host drawer to do?

With the Device Hosts drawer, you can connect yourself to the devices of
other people with TI Connect™ software. Connecting yourself to the devices
of other people or a classroom set of calculators lets you find information on
their devices and share information, files, and data with them.

Q:Why can’t I connect to other users in the Device Host drawer?

There are several reasons why this may happen:

• The user with whom you want to connect is not running TI Connect

Manager.

• You do not have Remote Apple Event Sharing turned on.

• You are not using the correct user name and/or password.

Q: Can I connect to someone who is not in my local area network?

Yes. To connect with someone who is not in your local area network, you
must create a device host for them.(See "Creating device host groups" on
page 63.)

Error messages

Error Message Possible causes or solutions

This screen could not be

retrieved.

TI Device Explorer cannot capture the

screen from your device. Make sure

TI Connectivity Cable is securely

connected to the device and computer,

refresh the TI Device Explorer window,

and then try again.
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Error Message Possible causes or solutions

The device device name got
an error while trying to

refresh. Please check the

connections.

This may be caused by either of the

following:

• The device is not connected

properly. Check to make sure your

device is properly connected and

then try again.

• The device has an older operating

system. Update the device operating

system and try again.

TI Communication Manager

quit. Would you like to restart

it or quit TI Device Explorer?

An error occurred during the

communication process. To relaunch

TI Device Explorer, click Launch.

The clock could not be

updated.

TI Device Explorer cannot update the

clock for the specified device. Make sure

TI Connectivity Cable is securely

connected to the device and computer,

refresh the TI Device Explorer window,

and then try again.

Sending questions to Texas Instruments

If you encounter a problem while using TI Device Explorer that appears to be
an issue with the software, you can alert Texas Instruments to the situation.

To send questions to Texas Instruments

1. Click TI Device Explorer > Send Questions to TI... .
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2. In the subject line, type a subject for the feedback.

3. In the main window, type the relevant information.

4. Click Send.

Glossary

This section provides reference material that you may find helpful while
using TI Device Explorer. In it, you can find terminology, file type
explanations, and icon explanations.

Terminology

12 hours format - Format that gives the time as AM/PM. For example, the
time reads 6:30 AM in the morning and 6:30 PM at night.

24 hours format - Format that gives military time. For example, the time
reads 6:30 in the morning and 18:30 at night.

application - 1: Software designed to run on a TI handheld device, such as
TI CellSheet™ Converter. Also called an App. 2: Software you can use with a
TI handheld device, such as TI Device Explorer. More commonly called a
tool.

archive - Storage of data, programs, and variables so that you cannot edit,
delete, or execute them.

battery state - Indicates whether or not the battery needs replacement.

backup folder - A folder that contains all of a device’s backed up files.
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border - A black box placed around an image.

capture To copy a device screen into the Screen Capture window and open
it as an image.

clock type - The type of clock on the connected device, either 12 hours clock
or 24 hours clock.

clock state - Indicates whether the clock is on or off.

connection ID - The identification number of the connected device.

copy - To make a duplicate of a file and move that duplicate to a new
location.

data variable - A group of variables you can create for a TI graphing
calculator, including matrix, list, string, and number variables.

date format - The format of the date on the connected device.

device - One of the following TI graphing calculators: TI-73, TI-82, TI-83,
TI-83 Plus, TI-83 Plus Silver Edition, TI-84 Plus, TI-84 Plus Silver Edition, TI-
84 Plus C Silver Edition, TI-85, TI-86, TI-89, TI-89 Titanium, TI-92, TI-92 Plus,
Voyage™ 200 PLT, TI Presenter, CBL 2.

device host - One of the other TI Connect™ users currently using the TI
Connect™ software.

distribution list - A list that contains a set of search criteria TI Device Explorer
can use to determine which connected devices to show in the window.

download - To transfer a file to a computer.

drag-and-drop - A process of transferring files where you click on a file, drag
the file to the new location, and drop the file there.

edit 1: To make changes to file data. 2: To make changes to an image using
an image editor.

hardware version - Indicates the version of the hardware installed on the
connected device.

image - A screen captured from a connected device.

image editor - A graphics program where you can make changes to an
image.

image var - A TI-84 Plus C Silver Edition image variable.

language - The language on the device. For example, English (USA).
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merged view - TI Device Explorer window view that shows the files of all
connected devices merged together.

normal view - TI Device Explorer window view that shows files under a
device name folder.

OS version - The version of the operating system on the connected device.

picture clipping - A copy of a captured screen stored as a file.

product ID - The type of connected device.

refresh - To update TI Device Explorer with any changes made to the device
files, or to load the files of a new device into TI Device Explorer.

ROM version - The version of the read-only (built in) memory on the
connected device.

screen capture - A screen captured (copied) from a connected TI handheld
device.

tool - A computer software application you can use with a TI handheld
device.

upload - To transfer a file to a TI handheld device.

File Types

Application (App) (*.XXk) - A handheld software application file (such as TI
CellSheet™ Converter, TI StudyCards™ Creator, TI NoteFolio™ Creator,
TI LearningCheck™ Creator, etc.) Examples: calctool.89k, areaform.8xk.

Application Variable file (AppVar) (*.XXv, *.XXc, *.XXy) - A file that contains
data for specific TI graphing calculators. Also called an AppVar. Examples:
var01.8xv, var01.89c.

Data file (*.TIData) - A file that contains spreadsheet data for a TI graphing
calculator.

Equation file (*.XXy) - A file that contains an equation (function) stored in the
Y= editor of a graphing calculator. Examples: Y1.8xy, Y3.73y.

Expression file (*.XXe) - A file containing a mathematical expression
(numbers, variables, operators, and so on) that evaluates a single number.
Related to a Number file. Examples: Folder1.express.9Xe, main.differ.V2e.
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Group file (*.XXg) - A collection of files stored together as one file.
Examples: NEWGROUP.8xg, TI92Lists.9Xg.

Group file (8xo) - A collection of files stored together as one file.The 8xo file
is unique to the Mac. The 8xo file is not compatible with the TI Connect PC
version. Example: NEWGROUP.8xo.

Graphing Calculator Software Application file (App) (*.XXk) - A file that
contains an application created for specific TI graphing calculators.
Examples: speller.8xk, timlin.9xk.

List file (*.TIList, *.XXl) - A file that contains a List variable for a TI graphing
calculator. Examples: L2.73I, L3.TIList.

Matrix file (*.TIMatrix, *.XXm) - A file that contains a Matrix variable for a
TI graphing calculator. Examples: A.TIMatrix, Matrix.V2m.

Number file (*.TINumber, *.XXn) - A file that contains a Number variable for
a TI graphing calculator. Examples: A.TINumber, Q.8Xn.

Pic Vars on TI-84 Plus (.8xi) - The Pic Vars are created and stored in RAM
or Archive. . Example: picture.8xi.

Pic Vars on TI-84 Plus C Silver Edition (8ci) - The Pic Vars are created and
modified on the device, but can not be shared with a TI-84 Plus. Pic Vars live
in archive memory only in the TI-84Plus Silver Edition. Example: picture 8ci.

Image Vars on the TI-84 Plus C Silver Edition (.8ca) - Image Vars are
created by converting a picture which can then be displayed in the graph
area. Examples: image.8ca.

Picture file (*.tiff, gif, jpg, and png) - A graphic file that contains a saved
captured screen. Examples: HomeScreen.tiff, TI83Pict.tiff.

Picture clipping file (*.pictClipping) - A graphic file that contains a saved
captured screen. Examples: MyPicture.pictClipping; Picture clipping
1.pictClipping.

Program file (*.TIProgram, *.XXp) - A file that contains a program created for
a TI graphing calculator. Examples: MyProgram.TIProgram, Circle.8xp.

QuickTime™ file (*.mov) - A file that contains a QuickTime movie file.
Examples: SetDate.mo, Graph1.mo.

Screenshot file (*.XXi) - A graphic file for a specific TI graphing calculator.
Example: Screen.73i.
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String file (*.TIString) - A file that contains a string variable for a TI graphing
calculator. Examples: B.TIString, Hello.TIString.

Text file (*.TIText, *.txt) - A file that contains text data for a TI graphing
calculator. Examples: Schedule.TIText, Assignments.txt.

Vector file (*.TIVector, *.86v) - A file that contains a vector variable for a
TI graphing calculator. Example: Vector1.TIVector, v1.86v.

Icons

Name Icon Name Icon

Application List

Application Variable Locked File

Archived File Matrix

Clock Number

Data Picture

Device Information Program

Device Settings Range

Equation Screenshot

Expression String
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Folder Table

Group Text

ID List Vector
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Introduction to TI Data Editor

TI Data Editor is a tool in the TI Connect™ software that you can use to create
and work with data for TI graphing calculators.

Once you create the data, you can then use TI Data Editor to edit it or share it
with your computer and TI graphing calculator.

TI Matrix window

In the TI Matrix window, you can create and edit matrix variables.

window control buttons - Buttons used to close, minimize, or expand

the window.

column control - Used to add or remove columns.

row control - Used to add or remove rows.

column letter - The letter that identifies the column.

row number - The number that identifies the row.

cell - The Matrix variable table where you type data.
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TI Text window

In the TI Text window, you can create text files for the TI-89 Family, TI-92 and
TI-92 Plus devices, and the Voyage™ 200 Personal Learning Tool.

window control buttons - Buttons used to close, minimize, or

expand the window.

main viewing area - Window where you type text.

TI List window

In the TI List window, you can create and edit list variables for TI graphing
calculators.
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window control buttons - Buttons used to close, minimize, or

expand the window.

row control - Used to add or remove rows.

column letter - The letter that identifies the column.

cell - The space in the List variable table where you type data.

row number - The number that identifies the row.

TI Data window

In the TI Data window, you can create and edit TI data variables for TI-84
Plus Family, TI-89 Family, TI-92, and TI-92 Plus devices and the
Voyage™ 200 Personal Learning Tool.
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window control buttons - Buttons used to close, minimize, or

expand the window.

column letter - The letter that identifies the column.

cell - TI Data variable table where you type the data.

row number - The number that identifies the row.

TI Vector window

In the TI Vector window, you can create and edit vector variables for the
TI-85 and TI-86 devices. Note that only these devices have a separate vector
category for data. In other devices, vectors are a subset of the list data file.
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window control buttons - Buttons used to close, minimize, or

expand the window.

row control - Used to add or remove rows.

column letter - The letter that identifies the column.

cell - The space in the Vector variable table where you type the

data.

row number - The number that identifies the row.

TI Program window and drawer

In the TI Program window, you can create and edit programs for TI graphing
calculators. This example shows the TI Program window with its auto-
complete drawer open.

Note:When you open the window, the auto-complete drawer may not be

open. Use the View menu to open and close this drawer.
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window control buttons - Buttons used to close, minimize, or

expand the window.

device control - Open the drop-down list to select the device type

for the program.

auto-complete drawer - The drawer that shows shortcuts for

entering functions. These shortcuts open in the drawer as you type

the program.

main viewing area - Area where you type the program.

TI String window

In the TI String window, you can create string variables for TI graphing
calculators.
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window control buttons - Buttons used to close, minimize, or

expand the window.

main viewing area - Area where you type a string variable.

TI Group window

In the TI Group window, you can create group files. Use a group file to send
a large number of files to your device at one time.

window control buttons - Buttons used to close, minimize, or

expand the window.

title bar - Identifies the type of information displayed. Clicking the

names in the title bar changes the way the TI Group window shows

the files.

main viewing area - Area where you can view the files.
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Opening TI Data Editor

Unlike the other TI Connect™ tools, TI Data Editor does not have a home
screen. Instead, TI Data Editor opens to a special dialog called the New
Document Chooser. This dialog enables you to select the type of data with
which you want to work.

To open TI Data Editor

1. On your desktop, double-click Macintosh HD .

2. Click the arrow by the Applications folder.
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3. Navigate to the TI Connect folder.

4. If the TI Connect folder is not open, click the arrow by the folder.

5. Double-click TI Data Editor.

The New Document Chooser dialog box opens.
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TI Number window

In the TI Number window, you can create and edit number variables.

window control buttons - Buttons used to close, minimize, or

expand the window.

main viewing area - Area where you type the number variable.

Closing TI Data Editor

You must close TI Data Editor from the menu bar, rather than the window. If
you close TI Data Editor from the window, the window closes but the
software remains open.

To close TI Data Editor

▶ In the menu bar, click TI Data Editor > Quit TI Data Editor.

TI Data Editor and its data type windows close.
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Creating data variables

TI Data Editor has four types of data that are considered data variables:
matrix variables, number variables, list variables, and string variables.

Creating matrix variables

Matrix variables contain numeric data stored in a two-dimension format with
one number per cell.

To create matrix variables

1. In the TI Data Editor menu, click File > New > TI Matrix.

2. Type the number of columns and press tab.

3. Type the number of rows and press tab.

4. Type the matrix data into the appropriate cells.

Note: Do not put commas, semi-colons, spaces, or tabs in the matrix
data.

5. Save the matrix variable. (See "Saving data" on page 122.)
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Creating number variables

Number variables contain numeric data stored in a single-number format
with one number per file.

To create number variables

1. In the TI Data Editor menu, click File > New > TI Number.

2. In the TI Number window, type the number.

3. Save the number variable. (See "Saving data" on page 122.)

Creating list variables

List variables contain numeric data stored in a single-column list.

To create list variables

1. In the TI Data Editor menu, click File > New > TI List.
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2. Type the number of cells and press Enter.

3. Type the list data into the appropriate cells.

Note: Do not put commas, semi-colons, spaces, or tabs in the list data.

4. Save the list variable. (See "Saving data" on page 122.)

Creating string variables

String variables are character sequences that define the text a program
shows or accept input from the keyboard in a program.

To create string variables

1. In the TI Data Editor menu, click File > New > TI String.

2. Type the string.

3. Save the string variable. (See "Saving data" on page 122.)

Creating TI data variables

While all of the variables you can create in TI Data Editor are technically
data variables, TI Data Editor also includes a specific TI data variable. The
TI data variable is similar to a spreadsheet. TI data variables can contain
both numeric and alphabetic data stored in a two-dimensional format. The
cells in TI data can contain entries of one or more numbers and letters.

To create TI data variables

1. In the TI Data Editor menu, click File > New > TI Data.
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2. Type the data into the appropriate cells.

Note: Use the character palette to enter special characters. (See

"Inserting special characters into data" on page 121.)

3. Save the data variable. (See "Saving data" on page 122.)

Creating vector variables

Vector variables are single-row matrices used to store data.

Note: Only the TI-85 and TI-86 consider vectors as a separate data type. For
other devices, vectors are treated as lists.

To create vector variables

1. Click File > New > TI Vector.
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2. Type the number of cells and press Enter.

3. Type the vector data into the appropriate cells.

Note: Do not put commas, semi-colons, spaces, or tabs in the vector
data.

4. Save the vector variable. (See "Saving data" on page 122.)

Creating programs

Programs are sets of commands that the TI graphing calculator carries out
as if you had typed them on the device. You can create programs using the
TI Program tool of TI Data Editor. Before you use TI Program to create a
program, you may want to become familiar with the catalog palette and the
auto-complete drawer. (See "Adding programming functions to data" on
page 119.)

To create programs

1. In the TI Data Editor menu, click File > New > TI Program.
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2. Click the Destination Device box.

A device type drop-down list opens.

3. Select the device type that will run the new program.

4. Type the program.

Note: You can select program functions from the catalog palette or

complete functions using the shortcuts in the auto-complete drawer.

Click View > Show Catalog Palette.
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5. Save the program. (See "Saving data" on page 122.)

Creating text files

A text file is a text-based document that you can store on the TI-84 Plus
family, TI-89, TI-92, TI-92 Plus, and Voyage™ 200 Personal Learning Tool.

To create text files

1. In the TI Data Editor menu, click File > New > TI Text.

2. Type the text.
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3. Save the text as a text file. (See "Saving data" on page 122.)

Creating group files

A group file is a file that contains a collection of device files stored together
as one file. The device files can come from any TI file type. Group files
provide a convenient way for you to send a large number of files to your
device at one time.

To create group files

1. In the TI Data Editor menu, click File > New > TI Group.

2. On your computer, locate the device files you want to store in the group

file.

3. Drag the device files to the TI Group window.

The TI Group window shows the name, kind, and size of each file.

Notes:

• If the destination platform dialog box opens, select a device type

from the list and click OK.

• If the invalid file name dialog box opens, enter or select a name and

click OK.
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Note: If the Native File dialog box opens, select a device type and click
OK.

4. Save the group file. (See "Saving data" on page 122.)

Working with data

TI Data Editor contains many different data types, including variables,
programs, and files. Once you create the data, you can use TI Data Editor to
edit it and use it with your computer and device.

Opening data files

You can open most data files in TI Data Editor, including data files created
on computers and data files created on TI graphing calculators. Data files
can contain variables, programs, text, or groups.

To open data files

1. In the TI Data Editor menu bar, click File > Open.

The Open dialog box opens.
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2. Navigate to the data file’s location.

3. Click the data file.

4. Click Open.

Note: For data files originally created on a TI graphing calculator, TI Data
Editor interprets the negate character (-) as a minus sign.

Selecting data

To perform an action on data, you must first select the data. The process of
selecting data varies among the different data types. Cells contain the data
for list and matrices, while the remaining data types contain textual data.

To select cells

You can select cells in any of the following ways:

• To select one cell, click the cell.

• To select multiple cells, hold down Command and click each cell.

• To select a cell row, click the row number.

• To select a cell column, click the column letter.

To select text

1. Click the beginning of the text.

2. Hold down Shift and click the end of the text.
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TI Data Editor highlights the selected text.

Editing data

The process of editing data varies among the different data types. Cells
contain the data for lists and matrices, while the remaining data types
contain textual data.

To change cell data

1. Double-click the cell.

TI Data Editor highlights the cell’s data.

2. Click the cell again.

A blinking cursor appears in the cell.

3. Make the necessary changes.

4. Press Enter.

To replace cell data

1. Click the cell.

TI Data Editor highlights the cell.

2. Type the new data.

3. Press Enter.

To change textual data

1. Click the location where you want to change the textual data.

2. Make the necessary changes.

To replace textual data

1. Select the data you want to replace.

2. Type the new data.

Copying data

You can copy variable, program, and text file data from one location to
another.
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To copy data

1. Select the data you want to copy.

2. Click Edit > Copy.

TI Data Editor puts a copy of the data on the clipboard.

3. To copy selected data to a different file, open an existing file or create a

new one.

4. Click the location where you want to copy the data.

5. Click Edit > Paste.

TI Data Editor copies the data to the new location.

Moving data

You can move variable, program, and text file data from one location to
another.

To move data

1. Select the data.

2. Click Edit > Cut.

TI Data Editor removes the data and places a copy of the data on the

clipboard.

Note: TI Data Editor does not let you have cells without data, so it
replaces any cell data you cut with a zero.

3. To move selected data to a different file, open an existing file or create a

new one.

4. Click the location where you want to move the data.

5. Click Edit > Paste.

TI Data Editor moves the data to the new location.

Deleting data

You can delete data from variables, programs, and files.

To delete data

1. Select the data.

2. Click Edit > Delete.
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TI Data Editor deletes the data. There is no delete confirmation

message, but you can undo a deletion.

Note: TI Data Editor does not let you have cells without data, so it
replaces any cell data you delete with a zero. The only exception to this

is for some instances of TI data variables. This data type can have an

“empty” cell, but an empty cell may change to an undefined cell.

Adding programming functions to data

In TI Data Editor, you can use the catalog palette to add functions to the data
in programs, text files, string variables, lists, matrices, vectors, and numbers.
The catalog palette contains a selection of the programming functions found
on TI graphing calculators. Using the catalog palette to add programming
functions to programs, text files, string variables, lists, matrices, vectors, and
numbers can make the process faster and easier for you.

Note: If the receiving device does not support this feature in lists, matrices,
vectors, or numbers, you will either receive an error message when the file is
sent to the device, or the unsupported item will be deleted when viewed on
the device.

To add programming functions to data

1. Click View > Show Catalog Palette.

The Catalog Palette window opens.

2. Click the device list.

A list of devices opens.
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3. Click the device you want.

4. In the first column of the Catalog Palette window, click the programming

function type you want.

A list of programming functions for the selected type opens in the

second column.

5. If necessary, continue to click programming function types until you

locate the function you need.

6. Double-click the function.

The function appears in the TI Program window.
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Inserting special characters into data

When you create or save your data, you may need to use system-provided
TI characters.

To insert special characters into data

You can insert special characters into text, program, and string data. Before
you insert the special characters, make sure that your device can support
them.

1. In the data window, place your cursor in the location where you want to

insert the special character.

2. Click Edit > Special Characters.

A list of text options opens.

3. Navigate to the character you need to add.

4. Double-click the character.

The software inserts the character in the selected location.

To add special characters to computer file names

1. In the Save As dialog, place your cursor in the location where you want

to insert the character.

2. Click Character Palette.
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The Characters dialog opens.

3. Navigate to the character you need to add.

4. Double-click the character.

The software inserts the character in the selected location.

Notes:

• Avoid adding special characters to the device file names. TI graphing

calculators cannot support many of the special characters.

• Because the character palette is system provided, it does not close

when you close the Save As dialog or when you close the TI Connect™

software. You must close the palette yourself when you finish using it.

Saving data

After you create or edit data for your TI graphing calculators, you can save it
for future use. You can save new data as a file, save changes to a data file,
or save a copy of a data file.

To save new data as a file

1. Click File > Save As.

The Save As dialog opens.
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Note: The Save As dialog may differ slightly from the image above,

depending upon the release of Mac OS X being utilized.

2. In the Save As dialog, type a computer file name.

Note: You may find that some names become highlighted as you type

them. This occurs when you type a reserve word or invalid name for the

device you specified. If you continue to type, you will find that the

highlighted letters are erased. To retain the highlighted letters, clear

highlighting and continue typing.

3. If necessary, navigate to a new save location.

4. Type a device file name. This is the name your file will have once it is

sent to your TI device.

5. If you are saving a program and want it protected, click Protected

Program.

Note: You cannot edit a Protected Program on the TI device.

6. Click Save.

TI Data Editor saves the data as a file.

To save changes to a data file

▶ Click File > Save.

TI Data Editor saves the changes to the data file.

Note: If you opened the file from TI Device Explorer, the software sends

the file back to the connected device instead of saving it on the

computer.

To save a copy of a data file

1. Click File > Save A Copy As.
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The Save As dialog opens.

Note: The Save As dialog for program data differs slightly from the

image above. It contains a Protected Program option.

2. In the Save As field, type a computer file name.

3. If necessary, navigate to a new save location.

4. Type a device file name. This is the name your file will have once it is

sent to your TI device.

5. If you are saving a copy of a program and want it protected, click

Protected Program.

6. Click Save.

TI Data Editor saves a copy of the data file.

Sending Data to TI Graphing Calculators

To send data to a selected device

1. If you have not already done so, save your data as a file.

2. Click the window of the data you want to send.

3. Click File > Send to Device.

The Send As dialog opens.
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4. Select the device to which you want to send the data.

A list of the device contents opens in the second column.
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5. If applicable, click the device folder to which you want to send the file.

A list of the device folder’s contents opens in the third column.

6. For devices without device folders, click the second column.

For devices with device folders, click the third column.

7. Type the name in the Send as field.

Note: You may find that some names become highlighted as you type

them. This occurs when you type a reserved word or invalid name for

the device you specified. If you continue to type, you will find that the

highlighted letters are erased. To retain the highlighted letters, clear

highlighting and continue typing.

8. Click Send.

TI Data Editor sends the file to the selected device.

Printing data

You can print any data type you create in TI Data Editor.
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To print data

1. Click the window of the data you want to print.

2. Click File > Print.

The Print dialog box opens

3. To expand the print options, click the down arrow to the right of the

Printer:

If necessary, change the print settings.

4. Click Print.

TI Data Editor prints the data.

Troubleshooting

This section contains information to help you quickly solve any problems you
may encounter while using TI Data Editor. If you are unable to find an
answer to your question here or in other sections of the help, visit
education.ti.com/go/download.

Frequently-asked questions

Q:What data types can I create in TI Data Editor?
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You can create matrix variables, text files, list variables, programs, string
variables, group files, vectors, data and number variables.

Q: Can I use all of the data types with any TI graphing calculator?

No. Some data types do not work on all devices.

Q:Why does TI Data Editor open to the New Document Chooser?

TI Data Editor does not have a main home screen. The software contains a
variety of tools that each have their own screen. When you open TI Data
Editor, it needs to know which screen to open.

Q:When I launch TI Data Editor, do I have to choose a new document from
the New Document Chooser?

No. You can also open previously saved data. (See "Opening data files" on
page 115.)

Q: Can I select items from the auto-complete drawer?

No. You must type the shortcuts in the auto-complete drawer.

Q: Can I drag functions from the catalog palette to a TI data variable
window?

No. You must double-click the items in the catalog palette to add them to the
TI Device Program window.

Q: In the Save As dialog, what does the Protect Program feature do?

Protect Program prevents the program from being edited on a TI graphing
calculator.

Q:Why did a zero replace the cell data I deleted?

A cell cannot be empty, so TI Data Editor replaces deleted cells with zeros.

Q: Can I delete a cell instead of just its data?

You can delete cells by removing rows and columns. However, this may
remove necessary data from your variable.

Q:When I open a data file that I created on my device, why does TI Data
Editor show the negate character (-) as a minus sign?

TI Data Editor interprets the negate character (-) as a minus sign. This gives

you the ability to later open the file in other software programs. Some

software programs, such as Excel, cannot recognize the negate character.

Q: Are there any characters I cannot use in data variables?
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Yes. With the matrix, list, data and number variables, you cannot use
commas, semi-colons, spaces, or tabs.

Q: Can I use complex numbers as data?

Yes. TI Data Editor supports complex numbers.

Q:Why does my matrix contain more columns on the device than it did when
I created it in TI Data Editor?

The matrix you created in TI Data Editor contains commas, semi-colons,
spaces, or tabs. The device interprets cells with these symbols as multiple
cells.

Q:Why does my list contain more numbers on the device than it did when I
created it in TI Data Editor?

The number you created in TI Data Editor contains commas, semi-colons,
spaces, or tabs. The device interprets these symbols as the beginning of a
new number. For example, if you put the number 1,400 in a list cell, the
device interprets it as {1 400}.

Q: Can I rename the individual files in my group?

Yes. Double-click the file name, type the new name, and press Enter.

System requirements

• Macintosh® OS X 10.6 (Snow Leopard) or later

• At least 512 MB RAM

• At least 40 MB hard disk space available

• Available USB port

• Internet access (direct or dial-up) required for TI Software Update and
TI OS Restore (full) functionality.

Error messages

Error Message Possible causes or solutions

TI Communication Manager

quit. Would you like to restart

it or quit TI Data Editor?

An error occurred during the

communication process. To restart

TI Data Editor, click Launch.
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Error Message Possible causes or solutions

The application TI Data

Editor has unexpectedly quit.

To close the error window, click Done. If

you need to continue, reopen TI Data

Editor.

Note: You lose all unsaved data when
this error occurs.

File is not valid. The data in the file you sent may contain

an e, +, or -. Sending list or matrix data

containing e, +, or - to a TI-89, TI-92, or

TI-92 Plus device or a Voyage™ 200

Personal Learning Tool results in an

invalid file error message.

Sending questions to Texas Instruments

If you encounter a problem while using TI Data Editor that appears to be an
issue with the software, you can alert Texas Instruments to the situation.

To send questions to Texas Instruments

1. Click TI Data Editor > Send Questions to TI....

The Feedback dialog opens.
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2. Type a subject for the feedback.

3. Type the relevant information.

4. Click Send.

Glossary

This section provides reference material that you may find helpful while
using TI Data Editor.

Terminology

application - 1: Software designed to run on a TI graphing calculator, such
as TI CellSheet™ Converter. Also called an App. 2: Software you can use
with a TI graphing calculator, such as TI Device Explorer. More commonly
called a tool.

data type - The type of data. For example, string.

data variable - A variable for your TI graphing calculator. This includes
matrix variables, list variables, string variables, and number variables.

device - One of the following TI graphing calculators: TI-73, TI-82, TI-83,
TI-83 Plus, TI-83 Plus Silver Edition, TI-84 Plus, TI-84 Plus Silver Edition,
TI-84 Plus C Silver Edition,TI-85, TI-86, TI-89, TI-89 Titanium, TI-92,
TI-92 Plus, Voyage™ 200 PLT, TI Presenter, CBL™ 2, CBR™ 2, LabPro®.

function - A basic computer operation that has a specific result.

numeric data - Data consisting of numbers.

tool - A computer software application you can use with a TI graphing
calculator.

two-dimensional - Made of multiple rows and columns. Matrices are two-
dimensional.

zero cell - A cell with the number 0 in it. It takes the place of a deleted or
cleared cell.

File types

Data file (*.TIData) - A file that contains spreadsheet data for a TI graphing
calculator.
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Group file (*.XXg) - A collection of files stored together as one file.
Examples: NEWGROUP.82, TI92Lists.9Xg.

Group file (8xo) - A collection of files stored together as one file. The 8xo file
is unique to the Mac. The 8xo file is not compatible with the TI Connect™
PC version. Example: NEWGROUP.8xo.

Note: The TI-83 Plus family and TI-84 Plus family group variable type is a
collection of items that are joined together and placed in archive on the
actual TI graphing calculator, and then sent as a single object (not multiple
transactions) to a computer via TI Connect™ software. This is an individual
data item and has to be returned to archive. If there is insufficient space on
the TI graphing calculator, the item will be rejected and you must free
archive in order to store it on the TI graphing calculator.

List file (*.TIList, *.XXl) - A file that contains a List variable for TI graphing
calculators. Examples: L2.73I, L3.TIList.

Matrix file (*.TIMatrix, *.XXm) - A file that contains a Matrix variable for a
TI graphing calculator. Examples: A.TIMatrix, Matrix.V2m.

Number file (*.TINumber, *.XXn) - A file that contains a Number variable for
a TI graphing calculator. Examples: A.TINumber, Q.8Xn.

Program file (*.TIProgram, *.XXp) - A file that contains a program created for
a TI graphing calculator. Examples: MyProgram.TIProgram,
Circle.TIProgram, test.89p.

String file (*.TIString) - A file that contains a string variable for a TI graphing
calculator. Examples: B.TIString, Hello.TIString, New.TIString.

Text file (*.TIText, *.xxt) - A file that contains text data for a TI graphing
calculator. Examples: Schedule.TIText, Assignments.9xt.

Vector file (*.TIVector) - A file that contains a vector variable for a
TI graphing calculator. Example: Vector1.TIVector.

Data types

data variable - Numeric and alphabetic data stored in a two-dimensional
format similar to a spreadsheet.

list variable - Numeric data stored in a single-column list.

group file - In TI Data Editor, a file that stores previously-created files
together.
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matrix variable - Numeric data stored in a two-dimensional format with one
number per cell.

number variable - Numeric data stored in a single-number format with one
number per file.

program - A set of commands that TI graphing calculators carry out as if you
had typed them on the calculator.

string variable - Sequences of characters that define the text that a program
shows or that accept input from the keyboard in a program.

text file - A text-based document that you can store on TI-89, TI-92, and
TI-92 Plus calculators and the Voyage™ 200 Personal Learning Tool.

vector variable - Single-row matrices that you can use to store data.
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Introduction to TI Software Update

TI Software Update is a tool in the TI Connect™ software that you can use to
update the software of a TI handheld device. The TI Software Update tool
supports the TI-73, TI-83 Plus Family, TI-84 Plus Family, TI-89 Titanium
Family, TI-89 Family, TI-92 Plus, and Voyage™ 200 Personal Learning Tool.

With TI Software Update, you can update device operating systems, free
applications, and purchased applications. You should update your device’s
software when new or updated software is available. By updating your
device’s software, you can expand the software’s current functions and
make it work more efficiently.

Before you start using TI Software Update, you should learn the basics of the
tool. This section covers the basic information you may need to know. It
describes the TI Software Update window; information on opening, closing,
and setting up TI Software Update; and information on setting up your
devices for use with TI Software Update.

TI Software Update window

The window has two views, normal view and merged view. Normal view
shows the connected devices with their files, while merged view shows a
combined list of all of the files on the connected devices.

Note:When you open the window, it may not have the log drawer open. You

can use the View menu to open and close this drawer. (See "Showing and

hiding the log" on page 142.)
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TI Software Update window (normal view)

.

window control buttons - Buttons used to close, minimize, or

expand the window.

toolbar visibility button - Hides or shows the toolbar.

toolbar - Provides button-accessed shortcuts to TI Software Update

functions.

title bar - Names the type of information below it, such as

application, size, and file type. Clicking the names in the title bar

changes the way TI software Update shows the availability updates.

device list - Lists the connected devices and the number of updates

available for them.

updates list - Lists the available updates for the connected device

(s). In normal view, it shows the connected device(s). In merged

view, it shows all of the files available.

log drawer - Shows the log for any recent update. In it, you can track

the progress of an update or determine why an update failed.
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TI Software Update Window (merged view)

window control buttons - Buttons used to close, minimize, or

expand the window.

toolbar display button - Hides or shows the toolbar.

toolbar - Provides button-accessed shortcuts to TI Software Update

functions.

title bar - Names the type of information below it, such as

application, size, and file type. Clicking the names in the title bar

changes the way TI software Update shows the availability updates

in the window.

updates list - Lists the available updates for the connected device

(s). In normal view, it shows the connected device(s). In merged

view, it shows all of the files available.

log drawer - Shows the log for any recent update. In it, you can track

the progress of an update or determine why an update failed.
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Opening TI Software Update

To open TI Software Update

1. On your desktop, double-click Macintosh HD .

2. Click the arrow by the Applications folder.

3. Navigate to the TI Connect™ folder.
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If the TI Connect™ folder is not open, click the arrow by the folder.

4. Double-click TI Software Update.

Note: If the TI Software Update window does not show the correct device(s),

disconnect the TI Connectivity Cable(s) from the computer and then

reconnect them.

Closing TI Software Update

You must close TI Software Update from the menu bar, rather than the
window. If you close TI Software Update from the window, the window closes
but the software remains open.

To close TI Software Update

▶ In the menu bar, click TI Software Update > Quit TI Software Update.
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Connecting and disconnecting TI handheld devices

You can connect your TI graphing calculators to your computer using either
of the following TI Connectivity Cables:

• USB Silver Edition cable

• USB computer cable (TI-84 Plus Family and TI-89 Titanium devices
only)

You should connect your devices each time you start the TI Connect™
software and then disconnect them when you finish. This helps the software
to recognize which devices you are using.

To connect TI handheld devices (USB Silver Edition cable)

1. Connect the USB Silver Edition cable to the device’s I/O port.

2. Connect the USB Silver Edition cable to the computer’s USB port.

If TI Software Update is running, the device appears in the window.

Note: If TI Software Update is running and the device does not appear in
the window, repeat steps 1 and 2.

To connect TI handheld devices (USB computer cable)

1. Connect the USB computer cable to the device’s USB port.

2. Connect the USB computer cable to the computer’s USB port.

If TI Software Update is running, the device appears in the window.

Note: If TI Software Update is running and the device does not appear in
the window, repeat steps 1 and 2.

To disconnect TI handheld devices (USB Silver Edition cable)

1. Disconnect the USB Silver Edition cable from the computer’s USB port.

2. Disconnect the USB Silver Edition cable from the device’s I/O port.

Note: If TI Software Update does not automatically remove disconnected

devices from the window, click Refresh .

To disconnect TI handheld devices (USB computer cable)

1. Disconnect the USB computer cable from the computer’s USB port.

2. Disconnect the USB computer cable from the device’s USB port.
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Note: If TI Software Update does not automatically remove disconnected

devices from the window, click Refresh .

Refreshing devices in the window

Refreshing the window lets the software detect changes to the connected
TI graphing calculators(s). For instance, if you download a purchased
software application, refresh removes the purchased software application
from the window.

To refresh devices in the window

▶ Click Refresh .

TI Software Update connects to the attached device(s), determines any

changes, and shows the refreshed information in the window.

Note: If this step does not refresh the devices in the window, disconnect
the TI Connectivity Cable(s) from the computer and then reconnect

them.

Checking devices

To make sure TI Software Update shows the connected devices accurately,
you can check devices. When you check devices, the software re-identifies
the connected devices and their needed updates.

To check devices

▶ Click Update > Check Devices.

TI Software Update identifies the connected devices, checks for updates,

and shows the devices and/or updates in the window.

Setting the download location

You may want to set the download location before you update your device
software. By default, TI Software Update downloads device software updates
to the desktop. You can change the download location to a more convenient
place using preferences.
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To set the downloaded location

1. In the menu bar, click TI Software Update > Preferences.

2. Click the General tab.

3. Click Select.

4. Navigate to the new save location.

5. Click Select.

TI Software Update changes the save location.
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Showing and hiding free device software

TI Software Update lets you decide whether or not you want to view
available free software. This makes it easier to find the updates you need.

To show free device software

▶ Click View > Show Free Updates or click Show Free .

TI Software Update shows the updates available for the free applications.

To hide free device software

▶ Click View > Hide Free Updates or click Hide Free .

TI Software Update hides the updates available for the free applications.

Showing and hiding the log

The log shows the status of your updates. Use the log to track the progress
of an update and, if necessary, locate any problems that occur during an
update.

To show the log

▶ Click View > Show Log or click Show Log .

The log drawer opens at the bottom of the TI Software Update window.

To hide the log

▶ Click View > Hide Log or click Hide Log .

The log drawer closes.
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Creating keychains

A keychain is a file that TI Software Update uses to automatically log you in
to the TI Online Store. If you are the only person who uses the TI Connect™
software, then creating a keychain saves you the time of logging in when
you want to update your software. However, if other people use the TI
Connect™ software, you may want to have each person log in separately. In
this case, you should not create a keychain.

To create keychains

1. Click the box by a device or a file.

A check mark appears in the box.

2. Click Update > Update Checked Items or click Update .

3. Type your User Name.

4. Type your password.

Note: If you have forgotten your password, go to the TI Education
Technology home page. Click the Sign In link, and follow the

instructions for obtaining your password.

5. Click Login.
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TI Software Update creates a keychain for you and then logs you into

the TI Online Store. A license agreement opens for the selected file.

6. To exit the license agreement, click Disagree.

-or-

To continue the update, click Agree.

Updating Device Software

You should update device software when new or updated software is made
available. Updating expands the software’s current functions and makes it
work more efficiently. With TI Software Update, you can update device
operating systems, purchased applications, and free applications.

Updating device operating systems

Use TI Software Update to update device operating systems. Updating your
operating system can give your device new features, support for new
accessories, and improved performance. You can update device operating
systems from normal or merged view.

Warnings:
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• Updating an operating system erases all data on your calculator.

• Do not disconnect a device during an OS update.

Before you start

• Make sure your device is properly connected to your computer.

• Make sure your device has good or new batteries.

• If you are in normal view and cannot see the device software files, click
the arrow to the left of the device.

To update device operating systems

1. Back up your device. (See the TI Device Explorer help.)

2. If the main window shows free updates, click View > Hide Free Updates

or click Hide Free .

TI Software Update hides the available free updates.

3. Click the box next to the operating system.

A check mark appears in the box.

4. Click Update > Update Checked Items or click Update .

5. Click Proceed.
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6. Read the license agreement, and then click Agree.

TI Software Update downloads the operating system to your device and

stores a copy of it on the computer (by default, it stores it on your

desktop). When the software finishes the download, a green check mark

appears next the operating system file in the main window.

Note: If you want to view the update progress, show the log. (See

"Showing and hiding the log" on page 142.)

Updating purchased device software

You can use TI Software Update to update the purchased software on your
device. Updating purchased device software keeps the software running as
efficiently as possible. You can update your purchased software from normal
or merged view.

Warning: Do not disconnect a device during a download.

Before you start

• Make sure you have the most current operating system on your device.
(See "Updating device operating systems" on page 144.)
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• Make sure your device is properly connected to your computer.

• Make sure your device has good or new batteries.

• If you are in normal view and cannot see the device software files, click
the arrow to the left of the device.

To update purchased device software

1. If the main window shows free updates, click View > Hide Free Updates

or click Hide Free .

TI Software Update hides the available free updates.

2. Click the box next to each file you want to update.

A check mark appears in the box(es).

3. Click Update > Update Checked Items or click Update .

4. For each license agreement, read the information, and then click Agree.
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TI Software Update downloads the selected files to your device and

stores a copy of the files on the computer (by default, it stores them on

your desktop). When the software finishes downloading, green check

marks appear in the main window next to the selected files.

Note: If you want to view the update progress, show the log. (See

"Showing and hiding the log" on page 142.)

Updating free device software

TI Software Update lists all free applications available for the connected
device(s). This means that it lists software already on your device and
software that is not on your device. Because of this, you can use TI Software
Update to both update your current free device software and acquire new
free device software.

Warning: Do not disconnect a device during a download.

Notes:

• TI Software Update does not remove downloaded free device software

updates from the list.

• TI Software Update lists free device software that does not need
updates.

Before you start

• Make sure your device has the most current operating system.

• Make sure your device is properly connected to your computer.

• Make sure your device has good or new batteries.

• If you are in normal view and cannot see the device software files, click

the arrow to the left of the device.

To update or acquire free device software

1. If the main window does not show free updates, click View > Show Free

Updates or click Show Free .

TI Software Update shows the available free updates.

2. Click the box next to each file you want to update or acquire.

A check mark appears in the box(es).
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3. Click Update > Update Checked Items or click Update .

4. For each license agreement, read the information and then click Agree.

TI Software Update downloads the selected files to your device and

stores a copy of the files on the computer (by default, it stores them on

your desktop). When the software finishes the download, a green check

mark appears in the main window next the selected files.

Note: If you want to view the update progress, show the log. (See

"Showing and hiding the log" on page 142.)

Customizing the toolbar

When you customize the toolbar, you can choose from a variety of options,
ranging from adding new items to the toolbar to changing the display of the
icons. Customizing the toolbar makes TI Software Update more convenient
and easier to use.

Hiding and showing the toolbar

You can choose whether or not to show the toolbar in the window.
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To hide the toolbar

▶ Click View > Hide Toolbar.

The window no longer shows the toolbar.

To show the toolbar

▶ Click View > Show Toolbar.

The window shows the toolbar.

Removing items from the toolbar

You can remove tools, separators, and spaces from the toolbar.

To remove items from toolbar

1. Click View > Customize Toolbar.

2. Drag the unwanted toolbar item to the Customize Toolbar dialog box.

3. Click Done.

Adding items to the toolbar

You can add tools, separators, and spaces to the toolbar.

To add items to the toolbar

1. Click View > Customize Toolbar.
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2. Drag the additional item to the main window’s toolbar.

3. Click Done.

Setting the toolbar to the default

When you first open a tool it shows a default toolbar. If you change the
toolbar and decide you do not want to keep the changes, you can always
revert back to the default.

To set the toolbar to the default

1. Click View > Customize Toolbar.

2. Drag the default set to the main window’s toolbar.

3. Click Done.
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Changing the display of icons and text

TI Software Update lets you change the icons and the text that displays in
the toolbar. You can choose to display both icons and text, only icons, or
only text.

To change the display of icons and/or text

1. Click View > Customize Toolbar.

2. From the Show drop-down list, select the option you want.

3. Click Done.

Changing the size of toolbar icons

TI Software Update lets you change the size of the icons in the toolbar.
Changing the size of the toolbar icons can help you to find and use them
more quickly.

To change the size of the icons

1. Click View > Customize Toolbar.
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2. Click Use Small Icons.

If Use Small Icons is off, TI Software Update turns it on. A check mark

appears and the icons in the toolbar become smaller.

If Use Small Icons is on, TI Software Update turns it off. The check mark

disappears and the icons in the toolbar become larger.

3. Click Done.

Troubleshooting

This section contains information to help you quickly solve any problems you
may encounter while using TI Software Update. If you are unable to find an
answer to your question here or in other sections of the help, visit the
TI-Cares KnowledgeBase at education.ti.com/go/download.

Frequently-asked questions

Q: Are there any devices that TI Software Update cannot update?

Yes. TI Software Update cannot update the following devices: TI-82, TI-83,
TI-85, TI-86, TI-92, CBL™, CBL™ 2, CBR™, LabPro®, or TI Presenter™.

Q: Can I change the computer location where the software downloads the
updates?

Yes. You can change the location under Preferences. (See "Setting the
download location" on page 140.)

Q: Can I back up my device in TI Software Update?

No. You must use TI Device Explorer to back up your device.
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Q: Can I cancel an update?

Yes. You can cancel an update in any of the following ways:

• In the Login dialog, click Cancel.

• In the License Agreement window, click Disagree.

• In the TI Software Update window, click Cancel .

Q: Can I download all available device updates at once?

Yes. In normal view, click the box by the device and then click Update >
Update Checked Items.

Note: TI Software Update lists all available free applications for your device.
If you choose this option, TI Software Update downloads files that you may

not want or need. To download updates only for files currently on your

device, click View > Hide Free Updates before you download the updates.

Q: How can I determine why an update failed?

Open the log. The log shows the progress of any update and any errors that
occurred during the update. (See "Showing and hiding the log" on page
142.)

Q: How many applications can I update at a time?

You can update as many applications as the Device Updates window
shows.

Q: Is there any way for me to view only the device files that need updates?

TI Software Update cannot distinguish between free applications that need
updates and those that do not. However, it can make this distinction for
operating systems and purchased applications. To view only operating
systems and purchased applications, click View > Hide Free Updates.

Q:What does the blue exclamation point symbol mean?

This symbol indicates an operating system that you need to download. You
must have the most recent operating system to download applications.

Q:What does the green check mark symbol mean?

This symbol indicates a successful update.
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Q:What should I do if TI Software Update does not show the connected
device(s)?

Disconnect the TI Connectivity Cable(s) from the computer and then
reconnect them. If TI Software Update still does not show the device, quit
TI Software Update and then open it again.

Q:Where are the software update files I downloaded to my desktop?

The software update files should be on your desktop. To see them, you may
need to click the desktop.

Q:Why are there no free applications in the Device Updates window?

TI Software Update is set to hide updates for free applications. (See
"Showing and hiding free device software" on page 142.)

Q:Why are my connected devices grayed out?

The devices are grayed out because they are not supported by TI Software
Update.

Q:Why is my connected device not in the TI Software Update window?

There are two reasons why this might happen:

• The TI Connectivity Cable is not connected correctly or needs to be

reconnected. Check the connection to the device and computer.

• You connected the device after you opened TI Software Update.

Click Refresh .

Q:Why does TI Software Update not remove downloaded free applications
when I click refresh?

TI Software Update lists all available free applications for the connected
device, even if you have downloaded them.

Q:Why does TI Software Update list more updatable files than I have on my
device?

TI Software Update lists all available free applications for the connected
device. This means that it includes both files currently on your device and
files that you have not yet acquired.

System requirements

• Macintosh® OS X 10.6 (Snow Leopard) or later
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• At least 512 MB RAM

• At least 40 MB hard disk space available

• Available USB port

• Internet access (direct or dial-up) required for TI Software Update and
TI OS Restore (full) functionality.

Error messages

Error Message Possible causes or solutions

TI Communication Manager quit.

Would you like to restart it or quit

TI Software Update?

An error occurred during the

communication process. To restart

TI Software Update, click Launch.

The application TI Software

Update has unexpectedly quit.

To close the error window, click

Done. If you need to continue, reopen

TI Software Update.

Note: You lose any unsaved data
when this error occurs.

Sending questions to Texas Instruments

If you encounter a problem while using TI Software Update that appears to
be an issue with the software, you can alert Texas Instruments to the
situation.

To send questions to Texas Instruments

1. Click TI Software Update > Send Questions to TI....
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2. In the subject line, type a subject for the feedback.

3. In the main window, type the relevant information.

4. Click Send.

Glossary

This section provides reference material that you may find helpful while
using TI Software Update. In it, you can find terminology and file type
explanations.

Terminology

application - 1: Software designed to run on a TI handheld device, such as
TI CellSheet™ Converter. Also called an App. 2: Software you can use with a
TI handheld device, such as TI DeviceExplorer. More commonly called a
tool.

cable - The item that connects your TI handheld device and your computer.
Generically called a TI Connectivity cable.

default - The way the software runs without instructions. In TI Software
Update, defaults that you can change include the toolbar, the save location,
and the display of free applications.

device - One of the following TI handheld devices: TI-73, TI-82, TI-83, TI-83
Plus, TI-83 Plus Silver Edition, TI-84 Plus Family, TI-85, TI-86, TI-89, TI-92,
TI-92 Plus, Voyage™ 200 PLT, TI Presenter, CBL 2.
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device file - A file created specifically for a TI handheld device.

device type - TI-73, TI-82, TI-83, TI-83 Plus, TI-83 Plus Silver Edition, TI-84
Plus Family, TI-85, TI-86, TI-89, TI-92, TI-92 Plus, Voyage™ 200 PLT,
TI Presenter, CBL 2.

download - To copy a file onto your computer.

drag-and-drop - To click a file and drag it to a new location.

keychain - A file that automatically logs you in to the TI Online Store.

log - The record of recent updates. In the log, you can view an update’s
status and/or determine any problems that occur during an update.

main window - The window that contains the toolbar you want to customize.

refresh - 1: (TI Software Update window) To update the window by
determining what devices are connected to the computer. 2: (Device
Updates window) To update the window by determining which applications
no longer need updates.

size - The number of bytes, kilobytes (KB), and megabytes (MB) of memory
an application takes up on your TI handheld device.

TI Device Explorer - A tool in the TI Connect™ software that lets you work
with the device files, device screens, and date/time on a TI handheld device.

TI Online Store Account - A free account with the TI Online Store that lets
you download software. It consists of your e-mail address and a password of
your choice.

tool - 1: A computer software application you can use with a TI handheld
device. 2: A button in the toolbar.

type - 1: (Normal View) The type of file: an operating system (OS), a
purchased application (Purchased), or a free application (Free). 2: (Merged
View) The type of device.

update - To find and download newer versions of the software (operating
system and applications) on your TI handheld device.

upload - To copy a file onto a TI handheld device.
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File Types

Operating System file (*.XXu) - A file that contains device operating system
software. Examples: Os160.73u, Os115.8xu, TI92base.9xu.

Handheld Software Application file (App) (*.XXk) - A file that contains an
application created for a specific TI handheld device. Examples: TICabri.89k,
TIFinance.9xk.
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Introduction to TI OS Restore

TI OS Restore is a tool in the TI Connect™ software that lets you restore
operating systems to devices that no longer have an operating system. Use
the TI OS Restore tool to restore the operating system of any connected TI
graphing calculator.

Opening TI OS Restore

TI OS Restore can open automatically when the software detects a device
without an operating system. However, you can open TI OS Restore
manually. To open TI OS Restore:

1. On your desktop, double-click Macintosh HD .

2. Click the arrow by the Applications folder.
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3. Navigate to the TI Connect folder.

If the TI Connect folder is not open, click the arrow by the folder name.

4. Double-click TI OS Restore.
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Closing TI OS Restore

You must close TI OS Restore from the menu bar, rather than the window. If
you close TI OS Restore from the window, the window closes but the
software remains open.

To close TI Device Explorer

▶ In the menu bar, click TI OS Restore > Quit TI OS Restore.
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Restoring device operating systems

The TI OS Restore tool only has one feature: restoring operating systems.
With TI OS Restore, you can restore the device operating system of any
connected TI graphing calculator.

To restore device operating systems:

1. Connect the device that needs an operating system.

The TI OS Restore window opens.

Note: If the TI OS Restore window does not open, you can open it

manually. (See Opening TI OS Restore.)

2. Make sure that the device shown in the TI OS Restore window is the

correct device. If it is not, select the correct device from the drop-down

list.

3. Click Download & Restore.
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TI OS Restores connects to the TI online store, locates the most current

operating system for the connected device, and downloads it to your

computer.

A dialog opens asking you to make sure the device is in the correct

state.

4. Click Proceed.

The software sends the OS to the device.
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Legal Information
This section contains important legal notices about this product, including
important information, service and support information, and the license
agreement.

Important Information

Except as otherwise expressly stated in the License that accompanies a
program, Texas Instruments makes no warranty, either express or implied,
including but not limited to any implied warranties of merchantability and
fitness for a particular purpose, regarding any programs or book materials
and makes such materials available solely on an "as-is" basis. In no event
shall Texas Instruments be liable to anyone for special, collateral, incidental,
or consequential damages in connection with or arising out of the purchase
or use of these materials, and the sole and exclusive liability of Texas
Instruments, regardless of the form of action, shall not exceed the amount set
forth in the license for the program. Moreover, Texas Instruments shall not be
liable for any claim of any kind whatsoever against the use of these
materials by any other party.

Copyright

© 2005 - 2013 Texas Instruments Incorporated

Trademarks

Mac® and Macintosh® are trademarks of their respective owners.

Texas Instruments Support and Service

For U.S. and Canada:

For General Information

Home Page: education.ti.com

KnowledgeBase and e-mail
inquiries:

education.ti.com/support
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Phone:

(800) TI-CARES / (800) 842-2737

For U.S., Canada, Mexico, Puerto

Rico, and

Virgin Islands only

International information: education.ti.com/international

For Technical Support

KnowledgeBase and support by e-mail: education.ti.com/support

Phone (not toll-free): (972) 917-8324

For Product (Hardware) Service

Customers in the U.S., Canada, Mexico, Puerto Rico and Virgin Islands:
Always contact Texas Instruments Customer Support before returning a
product for service.

For All Other Countries:

For general information

For more information about TI products and services, contact TI by e-mail or
visit the TI Internet address.

E-mail inquiries: ti-cares@ti.com

Home Page: education.ti.com

Service and Warranty Information

For information about the length and terms of the warranty or about product
service, refer to the warranty statement enclosed with this product or contact
your local Texas Instruments retailer/distributor.

Texas Instruments PC Software License Agreement

By downloading/installing this software and/or documentation, you agree to
abide by the following provisions.

1. License: Subject to your payment of any applicable license fee, Texas

Instruments Incorporated ("TI") grants you a license to copy and use the
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software program(s) and documentation from the linked web page or

CD ROM ("Licensed Materials"). In addition to the copy resident on your

computer, you may keep a copy on diskette or CD for backup / archive

purposes.

2. Restrictions: You may not reverse-assemble or reverse-compile the

software program portion of the Licensed Materials that are provided in

object code format. You may not sell, rent, or lease copies of the

Licensed Materials.

3. Support: Support for the Licensed Materials is described in the

documentation that accompanies the software. Absent such

documentation, support shall be provided by TI.

4. Copyright: The Licensed Materials and any accompanying

documentation are copyrighted. If you make copies, do not delete the

copyright notice, trademark, or protective notices from the copies.

5. Warranty: TI warrants that it has the right to provide the Licensed

Materials. TI does not warrant that the Licensed Materials will be free

from errors or will meet your specific requirements. The Licensed

Materials are made available "AS IS" to you or any subsequent user.

Although no warranty is given for the Licensed Material, the media (if

any) will be replaced if found to be defective during the first three (3)

months of use, when the package is returned postage prepaid to TI.

THIS PARAGRAPH EXPRESSES TI'S MAXIMUM LIABILITY AND

YOUR SOLE AND EXCLUSIVE REMEDY.

6. Limitations: Except as explicitly stated above, TI makes no warranty or

condition, either express or implied, including but not limited to any

implied warranties of merchantability and fitness for a particular

purpose, regarding the Licensed Materials.

In no event shall TI or its suppliers be liable for any indirect, incidental

or consequential damages, loss of profits, loss of use or data, or

interruption of business, whether the alleged damages are labeled in

tort, contract or indemnity.

Some states or jurisdictions do not allow the exclusion or limitation of

incidental or consequential damages, so the above limitation may not

apply.
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7. Additional terms: This Agreement will immediately terminate if you fail to

comply with its terms. Upon termination of this Agreement, you agree to

return or destroy the original package and all whole or partial copies of

the Program in your possession and so certify in writing to TI.

The export and re-export of United States original software and

documentation is subject to the Export Administration Act of 1969 as

amended. Compliance with such regulations is your responsibility. You

agree that you do not intend to nor will you, directly or indirectly, export,

re-export or transmit the Program or technical data to any country to

which such export, re-export or transmission is restricted by any

applicable United States regulation or statute, without the proper written

consent or license, if required of the Bureau of Export Administration of

the United States Department of Commerce, or such other

governmental entity as may have jurisdiction over such export, re-export

or transmission.

If the Program is provided to the U.S. Government pursuant to a

solicitation issued on or after December 1, 1995, the Program is

provided with the commercial license rights and restrictions described

elsewhere herein. If the Program is provided to the U.S. Government

pursuant to a solicitation issued prior to December 1, 1995, the Program

is provided with "Restricted Rights" as provided for in FAR, 48 CFR

52.227-14 (JUNE 1987) or DFAR, 48 CFR 252.227-7013 (OCT 1988),

as applicable.
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